aboutsummaryrefslogtreecommitdiffstats
path: root/math/openblas
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-11-23 14:13:51 +0800
committeryuri <yuri@FreeBSD.org>2018-11-23 14:13:51 +0800
commit80252979e81b265be698743db3baaebb6c5c9e57 (patch)
tree0680df6ae36394aeb066e8fa523bec9be48d43c2 /math/openblas
parentced849654c59184bb18946d6886e956563eddaae (diff)
downloadfreebsd-ports-gnome-80252979e81b265be698743db3baaebb6c5c9e57.tar.gz
freebsd-ports-gnome-80252979e81b265be698743db3baaebb6c5c9e57.tar.zst
freebsd-ports-gnome-80252979e81b265be698743db3baaebb6c5c9e57.zip
math/openblas: Increase the limit for the number of threads to unbreak other ports
NUM_THREADS= sets the build-time limit on the number of threads that apps can use with OpenBlas. This unbreaks at least science/erkale's tests, and possibly some other software. The upstream acknowledges the problem, recommended this solution for the port, and are working on the permanent solution: https://github.com/xianyi/OpenBLAS/issues/1882 Approved by: portmgr blanket (unbreak)
Diffstat (limited to 'math/openblas')
-rw-r--r--math/openblas/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index 9906c64666e7..a00324b009e5 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openblas
PORTVERSION= 0.2.20
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONPREFIX= v
PORTEPOCH= 1
CATEGORIES= math
@@ -58,7 +58,7 @@ AVX2_DESC= Support Advanced Vector Extensions 2 (AVX2)
BUILDFLAGS+= TARGET=${TARGET_CPU_ARCH}
.endif
-MAXTHREADS?= 8
+MAXTHREADS?= 64
BUILDFLAGS_THREAD+= NUM_THREADS=${MAXTHREADS} USE_THREAD=1
.if ${ARCH:M*64} == ""