aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Bit-ShiftReg
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:23:03 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:23:03 +0800
commit05e9f1e923e47ba8b24294f8f907df45e86d7eef (patch)
tree8cbae99ffe231d48703970941db801933de22510 /math/p5-Bit-ShiftReg
parentd5d27104ab937c0c6a8b3e677b66a583b93ad721 (diff)
downloadfreebsd-ports-gnome-05e9f1e923e47ba8b24294f8f907df45e86d7eef.tar.gz
freebsd-ports-gnome-05e9f1e923e47ba8b24294f8f907df45e86d7eef.tar.zst
freebsd-ports-gnome-05e9f1e923e47ba8b24294f8f907df45e86d7eef.zip
Add p5-Bit-ShiftReg 2.0, perl module implementing various bit shifting
operations.
Diffstat (limited to 'math/p5-Bit-ShiftReg')
-rw-r--r--math/p5-Bit-ShiftReg/Makefile23
-rw-r--r--math/p5-Bit-ShiftReg/distinfo1
-rw-r--r--math/p5-Bit-ShiftReg/pkg-comment1
-rw-r--r--math/p5-Bit-ShiftReg/pkg-descr11
-rw-r--r--math/p5-Bit-ShiftReg/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/math/p5-Bit-ShiftReg/Makefile b/math/p5-Bit-ShiftReg/Makefile
new file mode 100644
index 000000000000..d7ec884fa846
--- /dev/null
+++ b/math/p5-Bit-ShiftReg/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Bit-ShiftReg
+# Date created: Mon Jan 1 10:24:49 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Bit-ShiftReg
+PORTVERSION= 2.0
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Bit
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Bit::ShiftReg.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Bit-ShiftReg/distinfo b/math/p5-Bit-ShiftReg/distinfo
new file mode 100644
index 000000000000..1c0e2acace78
--- /dev/null
+++ b/math/p5-Bit-ShiftReg/distinfo
@@ -0,0 +1 @@
+MD5 (Bit-ShiftReg-2.0.tar.gz) = d8afa46eb43b252ae019c3193635d1e2
diff --git a/math/p5-Bit-ShiftReg/pkg-comment b/math/p5-Bit-ShiftReg/pkg-comment
new file mode 100644
index 000000000000..9b091beeb63a
--- /dev/null
+++ b/math/p5-Bit-ShiftReg/pkg-comment
@@ -0,0 +1 @@
+Perl module implementing various bit shifting operations
diff --git a/math/p5-Bit-ShiftReg/pkg-descr b/math/p5-Bit-ShiftReg/pkg-descr
new file mode 100644
index 000000000000..5f04e5ef7477
--- /dev/null
+++ b/math/p5-Bit-ShiftReg/pkg-descr
@@ -0,0 +1,11 @@
+Bit::ShiftReg is a perl module that implements rotate left, rotate
+right, arithmetic shift left, and logical shift right operations with
+carry flag for all C integer types. The results depend on the
+number of bits with that the integer types unsigned char, unsigned
+short, unsigned int, and unsigned long have on your machine. The
+module automatically determines the number of bits of each integer
+type and adjusts its internal constants accordingly.
+
+Author: Steffen Beyer <sb@sdm.de>
+
+--will
diff --git a/math/p5-Bit-ShiftReg/pkg-plist b/math/p5-Bit-ShiftReg/pkg-plist
new file mode 100644
index 000000000000..93de83e653ce
--- /dev/null
+++ b/math/p5-Bit-ShiftReg/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bit/ShiftReg.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bit/ShiftReg/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bit/ShiftReg/ShiftReg.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bit/ShiftReg/ShiftReg.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bit/ShiftReg