aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-Base85/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2001-09-18 05:47:14 +0800
committertobez <tobez@FreeBSD.org>2001-09-18 05:47:14 +0800
commitcd902c1f6ca5f73f89978b60dc523496599a55e7 (patch)
treeb277ccae98016b8cb19d8dc56f8f7465cdea2dc4 /math/p5-Math-Base85/Makefile
parent7fa5cb25ace571c43c5f361120e2896f6324a0c2 (diff)
downloadfreebsd-ports-gnome-cd902c1f6ca5f73f89978b60dc523496599a55e7.tar.gz
freebsd-ports-gnome-cd902c1f6ca5f73f89978b60dc523496599a55e7.tar.zst
freebsd-ports-gnome-cd902c1f6ca5f73f89978b60dc523496599a55e7.zip
Add p5-Math-Base85, a perl extension for base 85 numbers, as referenced
by RFC 1924.
Diffstat (limited to 'math/p5-Math-Base85/Makefile')
-rw-r--r--math/p5-Math-Base85/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/p5-Math-Base85/Makefile b/math/p5-Math-Base85/Makefile
new file mode 100644
index 000000000000..2f80094c5f3c
--- /dev/null
+++ b/math/p5-Math-Base85/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: math/p5-Math-Base85
+# Date created: 17 Sep 2001
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Base85
+PORTVERSION= 0.1
+CATEGORIES= math perl5 converters net
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::Base85.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+# workaround the bug in 5.005_03 and 5.6.0 :-(
+post-patch:
+ ${PERL} -pi -e 's|^use constant\s*(.*?)\s*=>.s*(.*)$$|sub $$1 { $$2 }|' ${WRKSRC}/Base85.pm
+
+.include <bsd.port.mk>