aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-BigInt
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2001-10-13 02:20:46 +0800
committertobez <tobez@FreeBSD.org>2001-10-13 02:20:46 +0800
commit78b65100f49f957c35818b21d5ab6c2b266e2652 (patch)
tree764fa4f37ddf07c13af7ad4bbc4516706ad30331 /math/p5-Math-BigInt
parent415e3f1a85460d15313d7ceb29c5e4cfe8be03c4 (diff)
downloadfreebsd-ports-gnome-78b65100f49f957c35818b21d5ab6c2b266e2652.tar.gz
freebsd-ports-gnome-78b65100f49f957c35818b21d5ab6c2b266e2652.tar.zst
freebsd-ports-gnome-78b65100f49f957c35818b21d5ab6c2b266e2652.zip
Add math/p5-Math-BigInt, an arbitrary size math package for perl. This
is a complete rewrite of the BigInt and BigFloat modules supplied with our standard system perl.
Diffstat (limited to 'math/p5-Math-BigInt')
-rw-r--r--math/p5-Math-BigInt/Makefile25
-rw-r--r--math/p5-Math-BigInt/distinfo1
-rw-r--r--math/p5-Math-BigInt/pkg-comment1
-rw-r--r--math/p5-Math-BigInt/pkg-descr9
-rw-r--r--math/p5-Math-BigInt/pkg-plist8
5 files changed, 44 insertions, 0 deletions
diff --git a/math/p5-Math-BigInt/Makefile b/math/p5-Math-BigInt/Makefile
new file mode 100644
index 000000000000..02d932e1211f
--- /dev/null
+++ b/math/p5-Math-BigInt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: math/p5-Math-BigInt
+# Date created: 12 October 2001
+# Whom: tobez
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-BigInt
+PORTVERSION= 1.44
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::BigFloat.3 \
+ Math::BigInt.3 \
+ Math::BigInt::Calc.3 \
+ Math::BigInt::Scalar.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-BigInt/distinfo b/math/p5-Math-BigInt/distinfo
new file mode 100644
index 000000000000..517927147022
--- /dev/null
+++ b/math/p5-Math-BigInt/distinfo
@@ -0,0 +1 @@
+MD5 (Math-BigInt-1.44.tar.gz) = 4a7810358d41ef922f7eb21dfb6927f3
diff --git a/math/p5-Math-BigInt/pkg-comment b/math/p5-Math-BigInt/pkg-comment
new file mode 100644
index 000000000000..85e01ff3f5ff
--- /dev/null
+++ b/math/p5-Math-BigInt/pkg-comment
@@ -0,0 +1 @@
+Math::BigInt - Arbitrary size integer math package
diff --git a/math/p5-Math-BigInt/pkg-descr b/math/p5-Math-BigInt/pkg-descr
new file mode 100644
index 000000000000..a3db2655aa33
--- /dev/null
+++ b/math/p5-Math-BigInt/pkg-descr
@@ -0,0 +1,9 @@
+Math::BigInt - Arbitrary size integer math package for perl.
+
+This is a complete rewrite of Math::BigInt, Math::BigFloat and friends,
+which are included with the standard system perl.
+
+WWW: http://search.cpan.org/search?dist=Math-BigInt
+
+-Anton
+<tobez@FreeBSD.org>
diff --git a/math/p5-Math-BigInt/pkg-plist b/math/p5-Math-BigInt/pkg-plist
new file mode 100644
index 000000000000..316b88eb8287
--- /dev/null
+++ b/math/p5-Math-BigInt/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math-BigInt/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Math/BigFloat.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/BigInt.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/BigInt/Calc.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/BigInt/Scalar.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math-BigInt
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Math/BigInt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Math 2>/dev/null || true