aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-BigRat/Makefile
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2005-03-04 03:19:32 +0800
committerskv <skv@FreeBSD.org>2005-03-04 03:19:32 +0800
commitab6720c23868894a7d92d55b5e73cb47b9cdbcf5 (patch)
tree803c61f24516fa982858cad943ed5396661a5b92 /math/p5-Math-BigRat/Makefile
parenta2177c837c958dcd27f45ae5eba227aa95baeab0 (diff)
downloadfreebsd-ports-gnome-ab6720c23868894a7d92d55b5e73cb47b9cdbcf5.tar.gz
freebsd-ports-gnome-ab6720c23868894a7d92d55b5e73cb47b9cdbcf5.tar.zst
freebsd-ports-gnome-ab6720c23868894a7d92d55b5e73cb47b9cdbcf5.zip
Add p5-Math-BigRat 0.14, arbitrary big rational numbers.
Diffstat (limited to 'math/p5-Math-BigRat/Makefile')
-rw-r--r--math/p5-Math-BigRat/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/p5-Math-BigRat/Makefile b/math/p5-Math-BigRat/Makefile
new file mode 100644
index 000000000000..6c5353f30bfc
--- /dev/null
+++ b/math/p5-Math-BigRat/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Math-BigRat
+# Date created: 03 March 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-BigRat
+PORTVERSION= 0.14
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Arbitrary big rational numbers
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::BigRat.3
+
+post-patch:
+ @${PERL} -pi -e '$$_="" if m/INSTALLDIRS/;' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>