aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-Derivative
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-11-26 08:05:56 +0800
committersem <sem@FreeBSD.org>2004-11-26 08:05:56 +0800
commit0ac6b56f1e144d0554a6156e1819db0e1a842b83 (patch)
treea6ddfaa179a785d507c9644d24d7482ae2816672 /math/p5-Math-Derivative
parent2238399561f02b6dc886c199dfc74efc77d5c302 (diff)
downloadfreebsd-ports-gnome-0ac6b56f1e144d0554a6156e1819db0e1a842b83.tar.gz
freebsd-ports-gnome-0ac6b56f1e144d0554a6156e1819db0e1a842b83.tar.zst
freebsd-ports-gnome-0ac6b56f1e144d0554a6156e1819db0e1a842b83.zip
[new port] math/p5-Math-Derivative
PR: ports/74381 Submitted by: Fernan Aguero <fernan(at)iib.unsam.edu.ar>
Diffstat (limited to 'math/p5-Math-Derivative')
-rw-r--r--math/p5-Math-Derivative/Makefile23
-rw-r--r--math/p5-Math-Derivative/distinfo2
-rw-r--r--math/p5-Math-Derivative/pkg-descr7
-rw-r--r--math/p5-Math-Derivative/pkg-plist5
4 files changed, 37 insertions, 0 deletions
diff --git a/math/p5-Math-Derivative/Makefile b/math/p5-Math-Derivative/Makefile
new file mode 100644
index 000000000000..98eb7186501b
--- /dev/null
+++ b/math/p5-Math-Derivative/Makefile
@@ -0,0 +1,23 @@
+# vim:ts=8
+# New ports collection makefile for: p5-Math-Derivative
+# Date created: 25 November 2004
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Derivative
+PORTVERSION= 0.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Numeric 1st and 2nd order differentiation
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::Derivative.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Derivative/distinfo b/math/p5-Math-Derivative/distinfo
new file mode 100644
index 000000000000..b648a71bf333
--- /dev/null
+++ b/math/p5-Math-Derivative/distinfo
@@ -0,0 +1,2 @@
+MD5 (Math-Derivative-0.01.tar.gz) = a359b1b4b545c03f4147594fc64420a2
+SIZE (Math-Derivative-0.01.tar.gz) = 1935
diff --git a/math/p5-Math-Derivative/pkg-descr b/math/p5-Math-Derivative/pkg-descr
new file mode 100644
index 000000000000..36a1e4b26110
--- /dev/null
+++ b/math/p5-Math-Derivative/pkg-descr
@@ -0,0 +1,7 @@
+This Perl package exports functions for performing numerical first
+(Derivative1) and second Derivative2) order differentiation on vectors
+of data. They both take references to two arrays containing the x and y
+ordinates of the data and return an array of the 1st or 2nd derivative
+at the given x ordinates. Derivative2 may optionally be given values to
+use for the first dervivative at the start and end points of the data -
+otherwiswe 'natural' values are used.
diff --git a/math/p5-Math-Derivative/pkg-plist b/math/p5-Math-Derivative/pkg-plist
new file mode 100644
index 000000000000..51810fba49cd
--- /dev/null
+++ b/math/p5-Math-Derivative/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Derivative/.packlist
+%%SITE_PERL%%/Math/Derivative.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Derivative
+@dirrm %%SITE_PERL%%/Math
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true