aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-Geometry-Planar/Makefile
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-22 07:25:32 +0800
committeraaron <aaron@FreeBSD.org>2006-05-22 07:25:32 +0800
commit022094d3a95e9532da746ef44e901705dd8d7808 (patch)
tree93820da73d385d34adf5190a80018452f785c579 /math/p5-Math-Geometry-Planar/Makefile
parent947fe61672db11c9cce56528093f9f0f61254a1f (diff)
downloadfreebsd-ports-gnome-022094d3a95e9532da746ef44e901705dd8d7808.tar.gz
freebsd-ports-gnome-022094d3a95e9532da746ef44e901705dd8d7808.tar.zst
freebsd-ports-gnome-022094d3a95e9532da746ef44e901705dd8d7808.zip
Adding port math/p5-Math-Geometry-Planar, a collection of planar geometry functions.
Approved by: tobez (implicit)
Diffstat (limited to 'math/p5-Math-Geometry-Planar/Makefile')
-rw-r--r--math/p5-Math-Geometry-Planar/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/p5-Math-Geometry-Planar/Makefile b/math/p5-Math-Geometry-Planar/Makefile
new file mode 100644
index 000000000000..db11b38e03ed
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-Geometry-Planar
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Geometry-Planar
+PORTVERSION= 1.16
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A collection of planar geometry functions
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Math/Geometry/Planar/GPC.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC \
+ ${SITE_PERL}/Math/Geometry/Planar/Offset.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-Offset
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Geometry::Planar.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>