aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-Int128/Makefile
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2012-12-20 16:47:10 +0800
committerjadawin <jadawin@FreeBSD.org>2012-12-20 16:47:10 +0800
commitd0457c92d7fa4bab11f666b00349db7bdb9c0902 (patch)
treed81619f5841416a0e0efd71042291d3ad396e1ec /math/p5-Math-Int128/Makefile
parent2be52328300036869705d59f0b1eae0a0abc5a20 (diff)
downloadfreebsd-ports-gnome-d0457c92d7fa4bab11f666b00349db7bdb9c0902.tar.gz
freebsd-ports-gnome-d0457c92d7fa4bab11f666b00349db7bdb9c0902.tar.zst
freebsd-ports-gnome-d0457c92d7fa4bab11f666b00349db7bdb9c0902.zip
Math::Int64 adds support for 64 bit integers, signed and unsigned, to Perl.
WWW: http://search.cpan.org/dist/Math-Int64/ PR: ports/174359 Submitted by: fbsd-ports@opsec.eu
Diffstat (limited to 'math/p5-Math-Int128/Makefile')
-rw-r--r--math/p5-Math-Int128/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/p5-Math-Int128/Makefile b/math/p5-Math-Int128/Makefile
new file mode 100644
index 000000000000..13ba86389371
--- /dev/null
+++ b/math/p5-Math-Int128/Makefile
@@ -0,0 +1,26 @@
+# Created by: Kurt Jaeger <fbsd-ports@opsec.eu>
+# $FreeBSD$
+#
+
+PORTNAME= Math-Int128
+PORTVERSION= 0.07
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fbsd-ports@opsec.eu
+COMMENT= Manipulate 128 bits integers in Perl
+
+LICENSE= ART10
+
+BUILD_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
+RUN_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
+
+PERL_CONFIGURE= yes
+
+USE_GCC= 4.4+
+
+MAN3= Math::Int128.3 \
+ Math::Int128::die_on_overflow.3
+
+.include <bsd.port.mk>