aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-Interpolate
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-03-13 00:05:40 +0800
committerlioux <lioux@FreeBSD.org>2001-03-13 00:05:40 +0800
commitb024d2efbd4f1c2825c5b7e8ab0743e48c70d2ab (patch)
tree06eec8f7a1eb2091d9dc5fbf017c923716e3269d /math/p5-Math-Interpolate
parentd59143058e96026d050096bc96070b5ff3032e52 (diff)
downloadfreebsd-ports-gnome-b024d2efbd4f1c2825c5b7e8ab0743e48c70d2ab.tar.gz
freebsd-ports-gnome-b024d2efbd4f1c2825c5b7e8ab0743e48c70d2ab.tar.zst
freebsd-ports-gnome-b024d2efbd4f1c2825c5b7e8ab0743e48c70d2ab.zip
New port:
Perl routines for data sets interpolation and interval search Initial import module version 1.05
Diffstat (limited to 'math/p5-Math-Interpolate')
-rw-r--r--math/p5-Math-Interpolate/Makefile22
-rw-r--r--math/p5-Math-Interpolate/distinfo1
-rw-r--r--math/p5-Math-Interpolate/pkg-comment1
-rw-r--r--math/p5-Math-Interpolate/pkg-descr24
-rw-r--r--math/p5-Math-Interpolate/pkg-plist6
5 files changed, 54 insertions, 0 deletions
diff --git a/math/p5-Math-Interpolate/Makefile b/math/p5-Math-Interpolate/Makefile
new file mode 100644
index 000000000000..a783030efb33
--- /dev/null
+++ b/math/p5-Math-Interpolate/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Math-Interpolate
+# Date created: 12 Mar 2001
+# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Interpolate
+PORTVERSION= 1.05
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lioux@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::Interpolate.3 Math::IntervalSearch.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Interpolate/distinfo b/math/p5-Math-Interpolate/distinfo
new file mode 100644
index 000000000000..fb5511821521
--- /dev/null
+++ b/math/p5-Math-Interpolate/distinfo
@@ -0,0 +1 @@
+MD5 (Math-Interpolate-1.05.tar.gz) = 1826c6c24b75a2a27964c3dac198adac
diff --git a/math/p5-Math-Interpolate/pkg-comment b/math/p5-Math-Interpolate/pkg-comment
new file mode 100644
index 000000000000..fcf562df9997
--- /dev/null
+++ b/math/p5-Math-Interpolate/pkg-comment
@@ -0,0 +1 @@
+Perl routines for data sets interpolation and interval search
diff --git a/math/p5-Math-Interpolate/pkg-descr b/math/p5-Math-Interpolate/pkg-descr
new file mode 100644
index 000000000000..7af9c0ed75ec
--- /dev/null
+++ b/math/p5-Math-Interpolate/pkg-descr
@@ -0,0 +1,24 @@
+This module contains several useful routines for interpolating data
+sets and finding where a given value lies in a sorted list.
+The first is a subroutine used to locate a position in an array of
+values where a given value would fit using bisection. It has been
+designed to be efficient in the common situation that it is called
+repeatedly. The user can supply a different set of comparison
+operators to replace the standard < and <=. For example, given a
+list (1, 2, 5, 8, 15) and the number 9.5 it would return 3.
+
+The remaining routines all are related to interpolating sets of
+(x,y) data pairs. They all take a list of (x,y) data pairs given
+another x value, return a sensible y value using the list of (x,y)
+data pairs. Three different interpolating functions are provided.
+The first, called a constant interpolator, assumes that the function
+being interpolated moves in non-linear jumps from one value to
+another. The interpolated value for some value x is the y value of
+the neighboring (x,y) to the left of the given x. The second
+interpolator performs a linear interpolation between the neighboring
+points. The third interpolator is called the robust interpolator
+and interpolates a smooth curve between all of the (x,y) pairs.
+To do the interpolation, it first calculates some reasonable
+derivatives at the (x,y) pairs. If you have measured your own
+derivative information, you can supply it to the robust interpolator
+and it will use it.
diff --git a/math/p5-Math-Interpolate/pkg-plist b/math/p5-Math-Interpolate/pkg-plist
new file mode 100644
index 000000000000..4c676d1f8326
--- /dev/null
+++ b/math/p5-Math-Interpolate/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Interpolate/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Math/Interpolate.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/IntervalSearch.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Math
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Interpolate
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math