aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-MPC/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-11 19:46:17 +0800
committermiwi <miwi@FreeBSD.org>2009-04-11 19:46:17 +0800
commitb567b68f5e297a522100a62fec6c508949d8b18a (patch)
tree315e7b7146faad0a91daac2d826831bbff1fc9eb /math/p5-Math-MPC/Makefile
parentd82a253377fe4042afca4a4ba14dea7461e83950 (diff)
downloadfreebsd-ports-gnome-b567b68f5e297a522100a62fec6c508949d8b18a.tar.gz
freebsd-ports-gnome-b567b68f5e297a522100a62fec6c508949d8b18a.tar.zst
freebsd-ports-gnome-b567b68f5e297a522100a62fec6c508949d8b18a.zip
p5-Math-MPC is a module wraps the MPC library functions.
The MPC library is a C library for multiple-precision complex number computations with exact rounding. It is based on the MPFR C library which, in turn, is based on the GMP C library. WWW: http://search.cpan.org/dist/Math-MPC PR: ports/133396 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'math/p5-Math-MPC/Makefile')
-rw-r--r--math/p5-Math-MPC/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/p5-Math-MPC/Makefile b/math/p5-Math-MPC/Makefile
new file mode 100644
index 000000000000..737180e43afd
--- /dev/null
+++ b/math/p5-Math-MPC/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Math-MPC
+# Date created: 05 April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-MPC
+PORTVERSION= 0.60
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A perl interface to MPC Library
+
+LIB_DEPENDS= mpc.1:${PORTSDIR}/math/mpc
+
+PERL_CONFIGURE= yes
+MAKE_ENV= INC="-I${LOCALBASE}/include"
+
+MAN3= Math::MPC.3
+
+.include <bsd.port.mk>