aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-Random-ISAAC-XS
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2009-12-07 22:41:50 +0800
committerwen <wen@FreeBSD.org>2009-12-07 22:41:50 +0800
commitc308d787784effe447168647609fb3e61480b976 (patch)
tree04851ac0179ee4446b4b85842a0d23afe0099e1d /math/p5-Math-Random-ISAAC-XS
parent0d900182ea009ac23526104855aeb612da20b50e (diff)
downloadfreebsd-ports-gnome-c308d787784effe447168647609fb3e61480b976.tar.gz
freebsd-ports-gnome-c308d787784effe447168647609fb3e61480b976.tar.zst
freebsd-ports-gnome-c308d787784effe447168647609fb3e61480b976.zip
As with other Pseudo-Random Number Generator (PRNG) algorithms like the
Mersenne Twister (see Math::Random::MT), this algorithm is designed to take some seed information and produce seemingly random results as output. However, ISAAC (Indirection, Shift, Accumulate, Add, and Count) has different goals than these commonly used algorithms. In particular, it's really fast - on average, it requires only 18.75 machine cycles to generate a 32-bit value. This makes it suitable for applications where a significant amount of random data needs to be produced quickly, such solving using the Monte Carlo method or for games. WWW: http://search.cpan.org/dist/Math-Random-ISAAC-XS/
Diffstat (limited to 'math/p5-Math-Random-ISAAC-XS')
-rw-r--r--math/p5-Math-Random-ISAAC-XS/Makefile24
-rw-r--r--math/p5-Math-Random-ISAAC-XS/distinfo3
-rw-r--r--math/p5-Math-Random-ISAAC-XS/pkg-descr12
-rw-r--r--math/p5-Math-Random-ISAAC-XS/pkg-plist11
4 files changed, 50 insertions, 0 deletions
diff --git a/math/p5-Math-Random-ISAAC-XS/Makefile b/math/p5-Math-Random-ISAAC-XS/Makefile
new file mode 100644
index 000000000000..a515e4bb0a93
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC-XS/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Math::Random::ISAAC::XS
+# Date created: 07 Dec, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Random-ISAAC-XS
+PORTVERSION= 1.001
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= C implementation of the ISAAC PRNG Algorithm
+
+BUILD_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Math::Random::ISAAC::XS.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Random-ISAAC-XS/distinfo b/math/p5-Math-Random-ISAAC-XS/distinfo
new file mode 100644
index 000000000000..d57346737136
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC-XS/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Random-ISAAC-XS-1.001.tar.gz) = 2656675416d9e36076016e73a2e326ff
+SHA256 (Math-Random-ISAAC-XS-1.001.tar.gz) = 357cd06bee82a51dd04511f9c35f96797264e41c36edc1339da13d2e464b3c34
+SIZE (Math-Random-ISAAC-XS-1.001.tar.gz) = 74962
diff --git a/math/p5-Math-Random-ISAAC-XS/pkg-descr b/math/p5-Math-Random-ISAAC-XS/pkg-descr
new file mode 100644
index 000000000000..c764bf79947d
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC-XS/pkg-descr
@@ -0,0 +1,12 @@
+As with other Pseudo-Random Number Generator (PRNG) algorithms like the
+Mersenne Twister (see Math::Random::MT), this algorithm is designed to
+take some seed information and produce seemingly random results as output.
+
+However, ISAAC (Indirection, Shift, Accumulate, Add, and Count) has
+different goals than these commonly used algorithms. In particular, it's
+really fast - on average, it requires only 18.75 machine cycles to generate
+a 32-bit value. This makes it suitable for applications where a significant
+amount of random data needs to be produced quickly, such solving using the
+Monte Carlo method or for games.
+
+WWW: http://search.cpan.org/dist/Math-Random-ISAAC-XS/
diff --git a/math/p5-Math-Random-ISAAC-XS/pkg-plist b/math/p5-Math-Random-ISAAC-XS/pkg-plist
new file mode 100644
index 000000000000..136dc108832d
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC-XS/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/ISAAC/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC/XS/XS.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/ISAAC/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/ISAAC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math