aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-Symbolic
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-15 14:11:36 +0800
committeraaron <aaron@FreeBSD.org>2006-05-15 14:11:36 +0800
commitfbdc269eda273b22870079ef174a2e1c3f92535b (patch)
treea8c8b73073289a52ca039354198c3a5b343b74c2 /math/p5-Math-Symbolic
parent9af46da5f4c562b3638e6e216f43f8025fd447c1 (diff)
downloadfreebsd-ports-gnome-fbdc269eda273b22870079ef174a2e1c3f92535b.tar.gz
freebsd-ports-gnome-fbdc269eda273b22870079ef174a2e1c3f92535b.tar.zst
freebsd-ports-gnome-fbdc269eda273b22870079ef174a2e1c3f92535b.zip
Adding port math/p5-Math-Symbolic, a library for dealing with symbolic math.
Approved by: tobez (implicit)
Diffstat (limited to 'math/p5-Math-Symbolic')
-rw-r--r--math/p5-Math-Symbolic/Makefile51
-rw-r--r--math/p5-Math-Symbolic/distinfo3
-rw-r--r--math/p5-Math-Symbolic/pkg-descr52
-rw-r--r--math/p5-Math-Symbolic/pkg-plist24
4 files changed, 130 insertions, 0 deletions
diff --git a/math/p5-Math-Symbolic/Makefile b/math/p5-Math-Symbolic/Makefile
new file mode 100644
index 000000000000..5a961489d620
--- /dev/null
+++ b/math/p5-Math-Symbolic/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: Math-Symbolic
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Symbolic
+PORTVERSION= 0.502
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Symbolic calculations
+
+BUILD_DEPENDS= ${SITE_PERL}/Memoize.pm:${PORTSDIR}/devel/p5-Memoize \
+ ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
+ ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Symbolic.3 \
+ Math::Symbolic::AuxFunctions.3 \
+ Math::Symbolic::Base.3 \
+ Math::Symbolic::Compiler.3 \
+ Math::Symbolic::Constant.3 \
+ Math::Symbolic::Custom.3 \
+ Math::Symbolic::Custom::Base.3 \
+ Math::Symbolic::Custom::DefaultDumpers.3 \
+ Math::Symbolic::Custom::DefaultMods.3 \
+ Math::Symbolic::Custom::DefaultTests.3 \
+ Math::Symbolic::Derivative.3 \
+ Math::Symbolic::ExportConstants.3 \
+ Math::Symbolic::MiscAlgebra.3 \
+ Math::Symbolic::MiscCalculus.3 \
+ Math::Symbolic::Operator.3 \
+ Math::Symbolic::Parser.3 \
+ Math::Symbolic::Parser::Precompiled.3 \
+ Math::Symbolic::Variable.3 \
+ Math::Symbolic::VectorCalculus.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Symbolic/distinfo b/math/p5-Math-Symbolic/distinfo
new file mode 100644
index 000000000000..22ad65ed212d
--- /dev/null
+++ b/math/p5-Math-Symbolic/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Symbolic-0.502.tar.gz) = c7c9de6cdbdb81ebb4fadd1431505677
+SHA256 (Math-Symbolic-0.502.tar.gz) = 91f845bd65e81a92663985eb563ec9b7c09b67e537c4dbee467a01722612bbf2
+SIZE (Math-Symbolic-0.502.tar.gz) = 97823
diff --git a/math/p5-Math-Symbolic/pkg-descr b/math/p5-Math-Symbolic/pkg-descr
new file mode 100644
index 000000000000..be575474b8cd
--- /dev/null
+++ b/math/p5-Math-Symbolic/pkg-descr
@@ -0,0 +1,52 @@
+Math::Symbolic is intended to offer symbolic calculation capabilities to
+the Perl programmer without using external (and commercial) libraries
+and/or applications.
+
+Unless, however, some interested and knowledgable developers turn up to
+participate in the development, the library will be severely limited by my
+experience in the area. Symbolic calculations are an active field of
+research in CS.
+
+There are several ways to construct Math::Symbolic trees. There are no
+actual Math::Symbolic objects, but rather trees of objects of subclasses
+of Math::Symbolic. The most general but unfortunately also the least
+intuitive way of constructing trees is to use the constructors of the
+Math::Symbolic::Operator, Math::Symbolic::Variable, and
+Math::Symbolic::Constant classes to create (nested) objects of the
+corresponding types.
+
+Furthermore, you may use the overloaded interface to apply the standard
+Perl operators (and functions, see "OVERLOADED OPERATORS") to existing
+Math::Symbolic trees and standard Perl expressions.
+
+Possibly the most convenient way of constructing Math::Symbolic trees is
+using the builtin parser to generate trees from expressions such as '2 *
+x^5'. You may use the Math::Symbolic->parse_from_string() class method for
+this.
+
+Of course, you may combine the overloaded interface with the parser to
+generate trees with Perl code such as "$term * 5 * 'sin(omega*t+phi)'"
+which will create a tree of the existing tree $term times 5 times the sine
+of the vars omega times t plus phi.
+
+There are several modules in the distribution that contain subroutines
+related to calculus. These are not loaded by Math::Symbolic by default.
+Furthermore, there are several extensions to Math::Symbolic availlable
+from CPAN as separate distributions. Please refer to "SEE ALSO" for an
+incomplete list of these.
+
+For example, Math::Symbolic::MiscCalculus come with Math::Symbolic and
+contains routines to compute Taylor Polynomials and the associated errors.
+
+Routines related to vector calculus such as grad, div, rot, and Jacobi-
+and Hesse matrices are availlable through the
+Math::Symbolic::VectorCalculus module. This module is also able to compute
+Taylor Polynomials of functions of two variables, directional derivatives,
+total differentials, and Wronskian Determinants.
+
+Some basic support for linear algebra can be found in
+Math::Symbolic::MiscAlgebra. This includes a routine to compute the
+determinant of a matrix of Math::Symbolic trees.
+
+WWW: http://search.cpan.org/dist/Math-Symbolic
+Author: Steffen Müller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-Symbolic/pkg-plist b/math/p5-Math-Symbolic/pkg-plist
new file mode 100644
index 000000000000..d911f8798f78
--- /dev/null
+++ b/math/p5-Math-Symbolic/pkg-plist
@@ -0,0 +1,24 @@
+%%SITE_PERL%%/Math/Symbolic.pm
+%%SITE_PERL%%/Math/Symbolic/AuxFunctions.pm
+%%SITE_PERL%%/Math/Symbolic/Base.pm
+%%SITE_PERL%%/Math/Symbolic/Compiler.pm
+%%SITE_PERL%%/Math/Symbolic/Constant.pm
+%%SITE_PERL%%/Math/Symbolic/Custom.pm
+%%SITE_PERL%%/Math/Symbolic/Custom/Base.pm
+%%SITE_PERL%%/Math/Symbolic/Custom/DefaultDumpers.pm
+%%SITE_PERL%%/Math/Symbolic/Custom/DefaultMods.pm
+%%SITE_PERL%%/Math/Symbolic/Custom/DefaultTests.pm
+%%SITE_PERL%%/Math/Symbolic/Derivative.pm
+%%SITE_PERL%%/Math/Symbolic/ExportConstants.pm
+%%SITE_PERL%%/Math/Symbolic/MiscAlgebra.pm
+%%SITE_PERL%%/Math/Symbolic/MiscCalculus.pm
+%%SITE_PERL%%/Math/Symbolic/Operator.pm
+%%SITE_PERL%%/Math/Symbolic/Parser.pm
+%%SITE_PERL%%/Math/Symbolic/Parser/Precompiled.pm
+%%SITE_PERL%%/Math/Symbolic/Parser/Yapp.pm
+%%SITE_PERL%%/Math/Symbolic/Variable.pm
+%%SITE_PERL%%/Math/Symbolic/VectorCalculus.pm
+@dirrm %%SITE_PERL%%/Math/Symbolic/Parser
+@dirrm %%SITE_PERL%%/Math/Symbolic/Custom
+@dirrm %%SITE_PERL%%/Math/Symbolic
+@dirrmtry %%SITE_PERL%%/Math