aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Math-TrulyRandom/Makefile
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2002-03-18 05:41:24 +0800
committeranders <anders@FreeBSD.org>2002-03-18 05:41:24 +0800
commit7d9d0294b526cd1f9543b2515a729c9b458f4c77 (patch)
tree4153538dbecdc695e6c5b9b5fa5add9cad62e9b9 /math/p5-Math-TrulyRandom/Makefile
parent3ef47ac0e5b5555883dd8458841c511599a22a89 (diff)
downloadfreebsd-ports-gnome-7d9d0294b526cd1f9543b2515a729c9b458f4c77.tar.gz
freebsd-ports-gnome-7d9d0294b526cd1f9543b2515a729c9b458f4c77.tar.zst
freebsd-ports-gnome-7d9d0294b526cd1f9543b2515a729c9b458f4c77.zip
Add Math::TrulyRandom, a Perl interface to a truly random number
generator function.
Diffstat (limited to 'math/p5-Math-TrulyRandom/Makefile')
-rw-r--r--math/p5-Math-TrulyRandom/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/p5-Math-TrulyRandom/Makefile b/math/p5-Math-TrulyRandom/Makefile
new file mode 100644
index 000000000000..18349f4c1210
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Math::TrulyRandom
+# Date created: 17 March 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-TrulyRandom
+PORTVERSION= 1.0
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= anders@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::TrulyRandom.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/truerand.c ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/truerand.h ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>