aboutsummaryrefslogtreecommitdiffstats
path: root/math/p5-Statistics-TTest
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-22 05:59:17 +0800
committermiwi <miwi@FreeBSD.org>2008-01-22 05:59:17 +0800
commit5f920006a3c39cb17ade31d06661aa7fd895d7e3 (patch)
treeb2527b64b2f1e6dfddb7434d321f7443283cc5f1 /math/p5-Statistics-TTest
parent38b03b32bb1d90ff92fbc0d9b647ed46b2c9b7dd (diff)
downloadfreebsd-ports-gnome-5f920006a3c39cb17ade31d06661aa7fd895d7e3.tar.gz
freebsd-ports-gnome-5f920006a3c39cb17ade31d06661aa7fd895d7e3.tar.zst
freebsd-ports-gnome-5f920006a3c39cb17ade31d06661aa7fd895d7e3.zip
This is the Statistical T-Test module to compare 2 independentsamples.
It takes 2 array of point measures, compute the confidence intervals using the PointEstimation module (which is also included in this package) and use the T-statistic to test the null hypothesis. If the null hypothesis is rejected, the difference will be given as the lower_clm and upper_clm of the TTest object. WWW: http://search.cpan.org/dist/Statistics-TTest/ PR: ports/119740 Submitted by: dawe <daweonline at gmail.com>
Diffstat (limited to 'math/p5-Statistics-TTest')
-rw-r--r--math/p5-Statistics-TTest/Makefile24
-rw-r--r--math/p5-Statistics-TTest/distinfo3
-rw-r--r--math/p5-Statistics-TTest/pkg-descr8
-rw-r--r--math/p5-Statistics-TTest/pkg-plist7
4 files changed, 42 insertions, 0 deletions
diff --git a/math/p5-Statistics-TTest/Makefile b/math/p5-Statistics-TTest/Makefile
new file mode 100644
index 000000000000..e8de718a4a04
--- /dev/null
+++ b/math/p5-Statistics-TTest/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: math/p5-Statistics-TTest
+# Date created: 17 January 2008
+# Whom: dawe <daweonline@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-TTest
+PORTVERSION= 1.1.0
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= daweonline@gmail.com
+COMMENT= Perl module to perform T-test on 2 independent samples
+
+BUILD_DEPENDS= p5-Statistics-Descriptive>=0:${PORTSDIR}/math/p5-Statistics-Descriptive
+
+PERL_CONFIGURE= yes
+
+MAN3= Statistics::TTest.3 Statistics::PointEstimation.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-TTest/distinfo b/math/p5-Statistics-TTest/distinfo
new file mode 100644
index 000000000000..460f9a414de6
--- /dev/null
+++ b/math/p5-Statistics-TTest/distinfo
@@ -0,0 +1,3 @@
+MD5 (Statistics-TTest-1.1.0.tar.gz) = 605466db48e2b16063abd16550e7d345
+SHA256 (Statistics-TTest-1.1.0.tar.gz) = b2d959d258c728479b7d862ee0146e5ad8eea989be25637cbc576552ff737166
+SIZE (Statistics-TTest-1.1.0.tar.gz) = 6013
diff --git a/math/p5-Statistics-TTest/pkg-descr b/math/p5-Statistics-TTest/pkg-descr
new file mode 100644
index 000000000000..eba71e41d708
--- /dev/null
+++ b/math/p5-Statistics-TTest/pkg-descr
@@ -0,0 +1,8 @@
+This is the Statistical T-Test module to compare 2 independentsamples.
+It takes 2 array of point measures, compute the confidence intervals
+using the PointEstimation module (which is also included in this package)
+and use the T-statistic to test the null hypothesis. If the null hypothesis
+is rejected, the difference will be given as the lower_clm and upper_clm of
+the TTest object.
+
+WWW: http://search.cpan.org/dist/Statistics-TTest/
diff --git a/math/p5-Statistics-TTest/pkg-plist b/math/p5-Statistics-TTest/pkg-plist
new file mode 100644
index 000000000000..7eca8185d40c
--- /dev/null
+++ b/math/p5-Statistics-TTest/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Statistics/PointEstimation.pm
+%%SITE_PERL%%/Statistics/TTest.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/TTest/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/TTest
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/Statistics