aboutsummaryrefslogtreecommitdiffstats
path: root/math/petsc/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-13 08:25:56 +0800
committermaho <maho@FreeBSD.org>2007-01-13 08:25:56 +0800
commit68869e0f511d299054faac77209ccda001bc5b73 (patch)
treef28c3dbabd5c9c4aadf3cdf2745c5c83874f9564 /math/petsc/Makefile
parentd6e557effd41bb7c8dca60df8efb5165a9f947f6 (diff)
downloadfreebsd-ports-gnome-68869e0f511d299054faac77209ccda001bc5b73.tar.gz
freebsd-ports-gnome-68869e0f511d299054faac77209ccda001bc5b73.tar.zst
freebsd-ports-gnome-68869e0f511d299054faac77209ccda001bc5b73.zip
* Migrate to gfortran.
* Bump port revision. * Use gfortran compiled atlas/blas/lapack.
Diffstat (limited to 'math/petsc/Makefile')
-rw-r--r--math/petsc/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 827490bf0bee..2307b355f21d 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= petsc
DISTVERSION= 2.3.2-p6
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= math parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
@@ -54,7 +54,7 @@ PLIST_SUB= PFX=${PFX} TARGET=${TARGET}
.if !defined(WITHOUT_UMFPACK)
LIB_DEPENDS+= umfpack.1:${PORTSDIR}/math/suitesparse
CONFIGURE_ARGS+= --with-umfpack-include="${LOCALBASE}/include/suitesparse" \
- --with-umfpack-lib=[${LOCALBASE}/lib/libumfpack.a,${LOCALBASE}/lib/libamd.a]
+ --with-umfpack-lib=[${LOCALBASE}/lib/libumfpack.so,${LOCALBASE}/lib/libamd.so]
.endif
.if !defined(NOPORTDOCS)
@@ -121,7 +121,7 @@ WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-LIBBLASLAPACK= "-L${LOCALBASE}/lib -lalapack -lf77blas -latlas -lm"
+LIBBLASLAPACK= "-L${LOCALBASE}/lib -lalapack -lf77blas -lcblas -latlas -lm"
CONFIGURE_ARGS+= --with-blas-lapack-lib=${LIBBLASLAPACK}
.else
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack