aboutsummaryrefslogtreecommitdiffstats
path: root/math/petsc/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-15 06:22:17 +0800
committermaho <maho@FreeBSD.org>2007-07-15 06:22:17 +0800
commitd5e90f38a6885323a29ca2b255bfeb0747e13fad (patch)
tree61a495e02e25fca76a49459952aa9ea5663e1c29 /math/petsc/Makefile
parent1e0153bb676773354cf231ae4b96d26d3260a29d (diff)
downloadfreebsd-ports-gnome-d5e90f38a6885323a29ca2b255bfeb0747e13fad.tar.gz
freebsd-ports-gnome-d5e90f38a6885323a29ca2b255bfeb0747e13fad.tar.zst
freebsd-ports-gnome-d5e90f38a6885323a29ca2b255bfeb0747e13fad.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
Diffstat (limited to 'math/petsc/Makefile')
-rw-r--r--math/petsc/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 1cb0f38add26..28e3c93dab52 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -43,10 +43,7 @@ CONFIGURE_ARGS+= --with-x-include=${X11BASE}/include \
--with-x-lib=${X11BASE}/lib/libX11.so
.endif
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
FFLAGS+= -O2
PFX= ${PORTNAME}
TARGET= ${OPSYS:L}