aboutsummaryrefslogtreecommitdiffstats
path: root/math/petsc/Makefile
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-11-22 19:14:10 +0800
committerbf <bf@FreeBSD.org>2011-11-22 19:14:10 +0800
commite76c3137d0dc704cf66c758a906a5be85b715a3b (patch)
tree5df944d34b65ba2c3cbfa92e36a81489e70a8220 /math/petsc/Makefile
parent79f1897cd8102cd7c050b91f5ec19e049be5fb80 (diff)
downloadfreebsd-ports-gnome-e76c3137d0dc704cf66c758a906a5be85b715a3b.tar.gz
freebsd-ports-gnome-e76c3137d0dc704cf66c758a906a5be85b715a3b.tar.zst
freebsd-ports-gnome-e76c3137d0dc704cf66c758a906a5be85b715a3b.zip
adjust linking and comments in dependent ports after the math/atlas update;
math/atlas-devel will be updated to use the same constructs at a later date PR: 162706 Approved by: miwi (portmgr) Feature safe: yes
Diffstat (limited to 'math/petsc/Makefile')
-rw-r--r--math/petsc/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index ef024397f83d..a744b0758aad 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -118,17 +118,17 @@ WITHOUT_SUPERLU= yes
PLIST_SUB+= MPIUNI=""
.endif
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-LIBBLASLAPACK= "-L${LOCALBASE}/lib -lalapack -lf77blas -lcblas -latlas -lm"
-CONFIGURE_ARGS+= --with-blas-lapack-lib=${LIBBLASLAPACK}
+LIBBLASLAPACK= -L${LOCALBASE}/lib -lalapack -lcblas -lf77blas
+CONFIGURE_ARGS+= --with-blas-lapack-lib="${LIBBLASLAPACK}"
.else
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-LIBBLASLAPACK= "-L${LOCALBASE}/lib -llapack -lblas -lm"
-CONFIGURE_ARGS+= --with-blas-lapack-lib=${LIBBLASLAPACK}
+LIBBLASLAPACK= -L${LOCALBASE}/lib -llapack -lblas
+CONFIGURE_ARGS+= --with-blas-lapack-lib="${LIBBLASLAPACK}"
.endif
.if !defined(WITHOUT_SUPERLU) && !defined(WITHOUT_BLASLAPACK)