aboutsummaryrefslogtreecommitdiffstats
path: root/math/petsc
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2009-11-28 18:44:56 +0800
committerthierry <thierry@FreeBSD.org>2009-11-28 18:44:56 +0800
commit821dbba052a0ebd1ff69db896a7e5af7c9a21fd9 (patch)
tree83ed04ecf451d9c7a671e32f6ad037860245534a /math/petsc
parent6156d85b8e504b4e5ea95a6e25e7d34c0e31fde6 (diff)
downloadfreebsd-ports-gnome-821dbba052a0ebd1ff69db896a7e5af7c9a21fd9.tar.gz
freebsd-ports-gnome-821dbba052a0ebd1ff69db896a7e5af7c9a21fd9.tar.zst
freebsd-ports-gnome-821dbba052a0ebd1ff69db896a7e5af7c9a21fd9.zip
- Chase relocation of net/mpich2
- Bump PORTREVISION if needed - Fix some portlint errors.
Diffstat (limited to 'math/petsc')
-rw-r--r--math/petsc/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 2fec4ee29837..80ba614cb627 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= petsc
DISTVERSION= 2.3.3-p0
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= math parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
@@ -65,7 +65,7 @@ PORTDOCS= *
LIBSCALAPACK= ${LOCALBASE}/lib/libscalapack.a
LIBBLACS= ${LOCALBASE}/lib/libblacs.a
-MPIDIR= ${LOCALBASE}/mpich2
+MPIDIR= ${LOCALBASE}
.include <bsd.port.pre.mk>
@@ -82,7 +82,7 @@ WITHOUT_SUPERLU= yes
WITH_MPI= yes
.endif
.if defined(WITH_MPI)
-. if exists(${LOCALBASE}/include/mpi.h)
+. if exists(${LOCALBASE}/bin/lamboot)
BROKEN= Cannot build with MPI when lam-7 is installed - set WITHOUT_MPI or deinstall net/lam
. endif
.if defined(WITH_OPENMPI)
@@ -97,8 +97,8 @@ WITHOUT_SPOOLES= yes
WITHOUT_PARMETIS= yes
CONFIGURE_ARGS+= --with-cc=${MPIDIR}/bin/mpicc --with-fc=${MPIDIR}/bin/mpif77
.else
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
PKGNAMESUFFIX+= -mpich
WITHOUT_SPOOLES= yes
.endif
@@ -139,7 +139,7 @@ CONFIGURE_ARGS+= --with-superlu-include=${LOCALBASE}/include/superlu \
CONFIGURE_ARGS+= --with-blocksolve95=0
.else
BUILD_DEPENDS+= ${LOCALBASE}/lib/libBS95.a:${PORTSDIR}/math/blocksolve95
-CONFIGURE_ARGS+= --with-blocksolve95-include=${LOCALBASE}/mpich2/include \
+CONFIGURE_ARGS+= --with-blocksolve95-include=${LOCALBASE}/include \
--with-blocksolve95-lib=${LOCALBASE}/lib/libBS95.a
.endif
@@ -288,12 +288,12 @@ regression-test:
${CHMOD} go-r ${HOME}/.mpd.conf
@${ECHO_MSG} "${HOME}/.mpd.conf has been generated - please change the secret word!"
. endif
- ${LOCALBASE}/mpich2/bin/mpd &
+ ${LOCALBASE}/bin/mpd &
. endif
(cd ${BUILD_WRKSRC}; \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
. if defined (WITH_MPI) && !defined(WITH_OPENMPI)
- ${LOCALBASE}/mpich2/bin/mpdallexit
+ ${LOCALBASE}/bin/mpdallexit
. endif
.endif