aboutsummaryrefslogtreecommitdiffstats
path: root/math/pgcalc/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-03-21 02:04:35 +0800
committerdanfe <danfe@FreeBSD.org>2005-03-21 02:04:35 +0800
commit6018399169d9a724cb804dce6aa081cc59c1f381 (patch)
tree6712dd1d52779bdb18d064066d5885f16dea073f /math/pgcalc/Makefile
parentc0812e66c7ec3a5fc3d9ace264fd7d7b972bf798 (diff)
downloadfreebsd-ports-gnome-6018399169d9a724cb804dce6aa081cc59c1f381.tar.gz
freebsd-ports-gnome-6018399169d9a724cb804dce6aa081cc59c1f381.tar.zst
freebsd-ports-gnome-6018399169d9a724cb804dce6aa081cc59c1f381.zip
PG Calculator is a very powerful scientific calculator, operating
in algebraic and RPN mode. Besides its functionality, it comes with different skins for GUI. Very cool. WWW: http://www.pgcalc.net/
Diffstat (limited to 'math/pgcalc/Makefile')
-rw-r--r--math/pgcalc/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/math/pgcalc/Makefile b/math/pgcalc/Makefile
new file mode 100644
index 000000000000..d19578ed4ad0
--- /dev/null
+++ b/math/pgcalc/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: PG Calculator
+# Date created: 20 Mar 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgcalc2
+DISTVERSION= 2.2-4
+CATEGORIES= math kde
+MASTER_SITES= http://www.pgcalc.net/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A powerfull scientific skinnable calculator
+
+USE_QT_VER= 3
+USE_KDELIBS_VER= 3
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= ARTS "Build with aRts support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_ARTS)
+CONFIGURE_ARGS+= --without-arts
+.endif
+
+post-extract:
+# Fix permissions for ``make clean'' to work
+ @${CHMOD} 755 ${WRKSRC}/skins/HP49G+
+ @${REINPLACE_CMD} -e 's,LIBS)$$,& $$(LIBPTHREAD),' \
+ ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -E 's,cp ([^-]*).* -r$$,${CP} -r \1,' \
+ ${WRKSRC}/Makefile.in
+# Remove backup leftovers (since installs via recursive copy)
+ @${FIND} ${WRKSRC}/skins -name \*~ -delete
+# Allow it to find its own skins
+ @${REINPLACE_CMD} -e 's,SkinPath =,& QString("${PREFIX}/share/apps/${PORTNAME}/skins/"); //,' \
+ ${WRKSRC}/src/pgcalc.cpp
+
+.include <bsd.port.post.mk>