aboutsummaryrefslogtreecommitdiffstats
path: root/math/php4-gmp
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2010-04-19 18:43:42 +0800
committerale <ale@FreeBSD.org>2010-04-19 18:43:42 +0800
commit6258613c3c402b1d7b5730e8a607d26dbb258755 (patch)
treefad3dbf503818032309e7103e30c646b5b51fdb7 /math/php4-gmp
parentdfb5167da9e4fc0c1a6e54c5bc4678fc695d9571 (diff)
downloadfreebsd-ports-gnome-6258613c3c402b1d7b5730e8a607d26dbb258755.tar.gz
freebsd-ports-gnome-6258613c3c402b1d7b5730e8a607d26dbb258755.tar.zst
freebsd-ports-gnome-6258613c3c402b1d7b5730e8a607d26dbb258755.zip
Switch to use newer GMP version.
PR: ports/144487 Submitted by: ale Approved by: portmgr (-exp run by erwin)
Diffstat (limited to 'math/php4-gmp')
-rw-r--r--math/php4-gmp/Makefile1
-rw-r--r--math/php4-gmp/files/patch-gmp.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/math/php4-gmp/Makefile b/math/php4-gmp/Makefile
index 1e1ce1033267..867d7e8fdd12 100644
--- a/math/php4-gmp/Makefile
+++ b/math/php4-gmp/Makefile
@@ -5,6 +5,7 @@
# $FreeBSD$
#
+PORTREVISION= 3
CATEGORIES= math
MASTERDIR= ${.CURDIR}/../../lang/php4
diff --git a/math/php4-gmp/files/patch-gmp.c b/math/php4-gmp/files/patch-gmp.c
new file mode 100644
index 000000000000..816d0f9b0f92
--- /dev/null
+++ b/math/php4-gmp/files/patch-gmp.c
@@ -0,0 +1,11 @@
+--- gmp.c.orig 2010-04-13 14:04:55.000000000 +0200
++++ gmp.c 2010-04-13 14:05:23.000000000 +0200
+@@ -1159,7 +1159,7 @@
+
+ GMPG(rand_initialized) = 1;
+ }
+- mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * __GMP_BITS_PER_MP_LIMB);
++ mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * GMP_LIMB_BITS);
+
+ ZEND_REGISTER_RESOURCE(return_value, gmpnum_result, le_gmp);
+ }