aboutsummaryrefslogtreecommitdiffstats
path: root/math/physcalc
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-23 01:06:27 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-23 01:06:27 +0800
commitc147389ae60aad271c5b1f86f9ba1368e91eb78b (patch)
treec30052169cd8bb432a4dc0eb35650e1f900ebcfa /math/physcalc
parent2789058898bc9e5f45b1cf4bd04aaffebbdd1626 (diff)
downloadfreebsd-ports-gnome-c147389ae60aad271c5b1f86f9ba1368e91eb78b.tar.gz
freebsd-ports-gnome-c147389ae60aad271c5b1f86f9ba1368e91eb78b.tar.zst
freebsd-ports-gnome-c147389ae60aad271c5b1f86f9ba1368e91eb78b.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39656 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'math/physcalc')
-rw-r--r--math/physcalc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/math/physcalc/Makefile b/math/physcalc/Makefile
index 7c2f05576cc6..e4b75f5d9432 100644
--- a/math/physcalc/Makefile
+++ b/math/physcalc/Makefile
@@ -17,6 +17,7 @@ EXTRACT_BEFORE_ARGS= -aq
EXTRACT_AFTER_ARGS= -x physcalc -d ${WRKDIR}
NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
USE_ZIP= yes
DEFS= -DSHAREDIR="\"${PREFIX}/share/physcalc/\""
@@ -24,7 +25,7 @@ SRCS= physconv.c physmain.c physmlib.c physnode.c physoper.c \
physsolv.c
pre-build:
- ${PERL} -pi -e "s@void main@int main@g" ${WRKSRC}/physmain.c
+ ${REINPLACE_CMD} -e "s@void main@int main@g" ${WRKSRC}/physmain.c
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} ${DEFS} ${SRCS} -lm -o physcalc)