aboutsummaryrefslogtreecommitdiffstats
path: root/math/plplot
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-06 06:17:49 +0800
committerpav <pav@FreeBSD.org>2006-06-06 06:17:49 +0800
commit4f2c386da989a4ef31cf90a0cdbe5c8e11f7b2c8 (patch)
tree429a9a399b3a02b6cadb6ad45f183d6ebf059deb /math/plplot
parent8e15b16879aea255207348be058f28317c66b0c7 (diff)
downloadfreebsd-ports-gnome-4f2c386da989a4ef31cf90a0cdbe5c8e11f7b2c8.tar.gz
freebsd-ports-gnome-4f2c386da989a4ef31cf90a0cdbe5c8e11f7b2c8.tar.zst
freebsd-ports-gnome-4f2c386da989a4ef31cf90a0cdbe5c8e11f7b2c8.zip
- Update to 5.6.1
PR: ports/98200 Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Diffstat (limited to 'math/plplot')
-rw-r--r--math/plplot/Makefile35
-rw-r--r--math/plplot/distinfo6
-rw-r--r--math/plplot/files/patch-pkgcfg::Makefile.in11
-rw-r--r--math/plplot/pkg-plist52
4 files changed, 35 insertions, 69 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 42cfa971dba3..8435dd2a3366 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= plplot
-PORTVERSION= 5.5.2
+PORTVERSION= 5.6.1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,13 +20,13 @@ LIB_DEPENDS= unicode.0:${PORTSDIR}/devel/libunicode \
qhull.5:${PORTSDIR}/math/qhull
USE_AUTOTOOLS= libltdl:15
+USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
M4="${LOCALBASE}/bin/gm4"
CONFIGURE_ARGS= --disable-cgm --disable-java --disable-octave \
- --with-ltdlsystem \
--with-gd-incdir=${LOCALBASE}/include \
--with-gd-libdir=${LOCALBASE}/lib \
--with-freetype-font-dir=${LOCALBASE}
@@ -42,6 +42,7 @@ PLIST_SUB+= X11="@comment "
.else
USE_XLIB= yes
PLIST_SUB+= X11=""
+#USE_GNOME= libgnomeui pkgconfig pango
.endif
.if !defined(WITHOUT_PTHREAD)
@@ -59,6 +60,7 @@ PLIST_SUB+= SVGALIB="@comment "
.if defined(WITH_PYTHON)
USE_PYTHON= yes
PLIST_SUB+= PYTHON=""
+CONFIGURE_ENV+= PYTHON_VERSION="${PYTHON_VERSION}"
.else
CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= PYTHON="@comment "
@@ -67,16 +69,16 @@ PLIST_SUB+= PYTHON="@comment "
.if defined(WITH_TCLTK)
.undef WITHOUT_X11
PKGNAMESUFFIX= -tcltk
-LIB_DEPENDS+= itk32.1:${PORTSDIR}/x11-toolkits/itk
-CONFIGURE_ENV+= ITKINCDIR="${LOCALBASE}/include/itk3.2" \
- ITKLIBDIR="${LOCALBASE}/lib" \
- TKINCDIR="${LOCALBASE}/include/tk8.3" \
- TKPRIVATEINCDIR="${LOCALBASE}/include/tk8.3/generic" \
- TKLIBDIR="${LOCALBASE}/lib" \
- ITCLINCDIR="${LOCALBASE}/include/itcl3.2" \
+LIB_DEPENDS+= itk.3:${PORTSDIR}/x11-toolkits/itk
+CONFIGURE_ENV+= ITKINCDIR="${LOCALBASE}/include/itk3.3" \
+ ITKLIBDIR="${LOCALBASE}/lib" \
+ TKINCDIR="${LOCALBASE}/include/tk8.4" \
+ TKPRIVATEINCDIR="${LOCALBASE}/include/tk8.4/generic" \
+ TKLIBDIR="${LOCALBASE}/lib" \
+ ITCLINCDIR="${LOCALBASE}/include/itcl3.3" \
ITCLLIBDIR="${LOCALBASE}/lib" \
- TCLINCDIR="${LOCALBASE}/include/tcl8.3" \
- TCLPRIVATEINCDIR="${LOCALBASE}/include/tcl8.3/generic" \
+ TCLINCDIR="${LOCALBASE}/include/tcl8.4" \
+ TCLPRIVATEINCDIR="${LOCALBASE}/include/tcl8.4/generic" \
TCLLIBDIR="${LOCALBASE}/lib"
MAN1+= plrender.1 plserver.1 pltcl.1
PLIST_SUB+= TCLTK=""
@@ -97,14 +99,13 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|-litk$$|-litk32|g ; \
- s|-ltk$$|-ltk83|g ; \
- s|-litcl$$|-litcl32|g ; \
- s|-ltcl$$|-ltcl83|g ; \
- s|-lpthread|${PTHREAD_LIBS:S/"//g}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-ltk$$|-ltk84|g ; \
+ s|-ltcl$$|-ltcl84|g ; \
+ s|-lpthread|${PTHREAD_LIBS:S/"//g}|g ; \
+ s|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|tk octave java|tk|g' \
${WRKSRC}/bindings/Makefile.in
- @${REINPLACE_CMD} -e 's| tclsh | ${LOCALBASE}/bin/tclsh8.3 |g' \
+ @${REINPLACE_CMD} -e 's| tclsh | ${LOCALBASE}/bin/tclsh8.4 |g' \
${WRKSRC}/scripts/mktclIndex
post-install:
diff --git a/math/plplot/distinfo b/math/plplot/distinfo
index 1f3f2829bf20..de405ed54bfc 100644
--- a/math/plplot/distinfo
+++ b/math/plplot/distinfo
@@ -1,3 +1,3 @@
-MD5 (plplot-5.5.2.tar.gz) = bef62f05b317005fbf36c2fc3c191338
-SHA256 (plplot-5.5.2.tar.gz) = 267d9c4070b8b6de75590efc24388da670dd5d0039a5dc21ecb803366d14730c
-SIZE (plplot-5.5.2.tar.gz) = 5891255
+MD5 (plplot-5.6.1.tar.gz) = 51029b256f3333449de9bcd3e00c088f
+SHA256 (plplot-5.6.1.tar.gz) = b2f1d93c605dd98bd95909ee9aca52d6c6cda476405b583f8a486f90aae893ad
+SIZE (plplot-5.6.1.tar.gz) = 6357444
diff --git a/math/plplot/files/patch-pkgcfg::Makefile.in b/math/plplot/files/patch-pkgcfg::Makefile.in
deleted file mode 100644
index 38f42c547cf5..000000000000
--- a/math/plplot/files/patch-pkgcfg::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- pkgcfg/Makefile.in.orig Mon Feb 2 20:41:08 2004
-+++ pkgcfg/Makefile.in Tue Feb 10 01:42:00 2004
-@@ -519,7 +519,7 @@
-
- info-am:
-
--install-data-am: install-pkgconfigDATA
-+install-data-am: @with_pkg_config_TRUE@install-pkgconfigDATA
- @$(NORMAL_INSTALL)
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
-
diff --git a/math/plplot/pkg-plist b/math/plplot/pkg-plist
index 5172556dd262..dcaf74f4efbd 100644
--- a/math/plplot/pkg-plist
+++ b/math/plplot/pkg-plist
@@ -35,27 +35,27 @@ lib/libcsironn.so.0
lib/libplplotcxxd.a
lib/libplplotcxxd.la
lib/libplplotcxxd.so
-lib/libplplotcxxd.so.10
+lib/libplplotcxxd.so.11
lib/libplplotd.a
lib/libplplotd.la
lib/libplplotd.so
-lib/libplplotd.so.10
+lib/libplplotd.so.11
lib/libplplotf77cd.a
lib/libplplotf77cd.la
lib/libplplotf77cd.so
-lib/libplplotf77cd.so.9
+lib/libplplotf77cd.so.10
lib/libplplotf77d.a
lib/libplplotf77d.la
lib/libplplotf77d.so
-lib/libplplotf77d.so.9
+lib/libplplotf77d.so.10
%%TCLTK%%lib/libplplottcltkd.a
%%TCLTK%%lib/libplplottcltkd.la
%%TCLTK%%lib/libplplottcltkd.so
-%%TCLTK%%lib/libplplottcltkd.so.10
+%%TCLTK%%lib/libplplottcltkd.so.11
%%TCLTK%%lib/libtclmatrixd.a
%%TCLTK%%lib/libtclmatrixd.la
%%TCLTK%%lib/libtclmatrixd.so
-%%TCLTK%%lib/libtclmatrixd.so.10
+%%TCLTK%%lib/libtclmatrixd.so.11
lib/plplot%%VERSION%%/driversd/gd.la
lib/plplot%%VERSION%%/driversd/gd.rc
lib/plplot%%VERSION%%/driversd/gd.so
@@ -80,9 +80,6 @@ lib/plplot%%VERSION%%/driversd/plmeta.so
lib/plplot%%VERSION%%/driversd/ps.la
lib/plplot%%VERSION%%/driversd/ps.rc
lib/plplot%%VERSION%%/driversd/ps.so
-lib/plplot%%VERSION%%/driversd/pstex.la
-lib/plplot%%VERSION%%/driversd/pstex.rc
-lib/plplot%%VERSION%%/driversd/pstex.so
%%TCLTK%%lib/plplot%%VERSION%%/driversd/tk.la
%%TCLTK%%lib/plplot%%VERSION%%/driversd/tk.rc
%%TCLTK%%lib/plplot%%VERSION%%/driversd/tk.so
@@ -99,6 +96,9 @@ lib/plplot%%VERSION%%/driversd/xfig.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/plplot.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/plplot_widgetmodule.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/plplotc.py
+libdata/pkgconfig/plplotd.pc
+libdata/pkgconfig/plplotd-c++.pc
+libdata/pkgconfig/plplotd-f77.pc
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/Copyright
@@ -111,14 +111,12 @@ lib/plplot%%VERSION%%/driversd/xfig.so
%%PORTDOCS%%%%DOCSDIR%%/README.csa
%%PORTDOCS%%%%DOCSDIR%%/README.drivers
%%PORTDOCS%%%%DOCSDIR%%/README.nn
+%%PORTDOCS%%%%DOCSDIR%%/README.pkg-config
%%DATADIR%%%%VERSION%%/cglobe.map
%%DATADIR%%%%VERSION%%/examples/Makefile
%%DATADIR%%%%VERSION%%/examples/c/Makefile
-%%DATADIR%%%%VERSION%%/examples/c/README.plplotcanvas
%%DATADIR%%%%VERSION%%/examples/c/lena.pgm
%%DATADIR%%%%VERSION%%/examples/c/plcdemos.h
-%%DATADIR%%%%VERSION%%/examples/c/plplotcanvas_animation.c
-%%DATADIR%%%%VERSION%%/examples/c/plplotcanvas_demo.c
%%DATADIR%%%%VERSION%%/examples/c/tutor.c
%%DATADIR%%%%VERSION%%/examples/c/x01c.c
%%DATADIR%%%%VERSION%%/examples/c/x02c.c
@@ -144,8 +142,10 @@ lib/plplot%%VERSION%%/driversd/xfig.so
%%DATADIR%%%%VERSION%%/examples/c/x22c.c
%%DATADIR%%%%VERSION%%/examples/c/x23c.c
%%DATADIR%%%%VERSION%%/examples/c/x24c.c
+%%DATADIR%%%%VERSION%%/examples/c/x25c.c
%%DATADIR%%%%VERSION%%/examples/c++/Makefile
%%DATADIR%%%%VERSION%%/examples/c++/lena.pgm
+%%DATADIR%%%%VERSION%%/examples/c++/plc++demos.h
%%DATADIR%%%%VERSION%%/examples/c++/x01.cc
%%DATADIR%%%%VERSION%%/examples/c++/x01cc.cc
%%DATADIR%%%%VERSION%%/examples/c++/x02.cc
@@ -191,32 +191,9 @@ lib/plplot%%VERSION%%/driversd/xfig.so
%%DATADIR%%%%VERSION%%/examples/f77/x16f.f
%%DATADIR%%%%VERSION%%/examples/f77/x17f.f
%%DATADIR%%%%VERSION%%/examples/f77/x18f.f
+%%DATADIR%%%%VERSION%%/examples/f77/x19f.f
%%DATADIR%%%%VERSION%%/examples/f77/x22f.f
-%%DATADIR%%%%VERSION%%/examples/perl/README.perldemos
-%%DATADIR%%%%VERSION%%/examples/perl/x01.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x02.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x03.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x04.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x05.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x06.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x07.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x08.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x09.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x10.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x11.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x12.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x13.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x14.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x15.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x16.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x17.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x18.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x19.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x20.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x21.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x22.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x23.pl
-%%DATADIR%%%%VERSION%%/examples/perl/x24.pl
+%%DATADIR%%%%VERSION%%/examples/f77/x23f.f
%%DATADIR%%%%VERSION%%/examples/plplot-test.sh
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/README.plplotcanvas
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/README.pythondemos
@@ -386,7 +363,6 @@ lib/plplot%%VERSION%%/driversd/xfig.so
%%TCLTK%%@dirrm %%DATADIR%%%%VERSION%%/examples/tk
%%TCLTK%%@dirrm %%DATADIR%%%%VERSION%%/examples/tcl
%%PYTHON%%@dirrm %%DATADIR%%%%VERSION%%/examples/python
-@dirrm %%DATADIR%%%%VERSION%%/examples/perl
@dirrm %%DATADIR%%%%VERSION%%/examples/f77
@dirrm %%DATADIR%%%%VERSION%%/examples/c++
@dirrm %%DATADIR%%%%VERSION%%/examples/c