aboutsummaryrefslogtreecommitdiffstats
path: root/math/plplot
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /math/plplot
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'math/plplot')
-rw-r--r--math/plplot/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 1a5f28b022e1..055ff6f3167d 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -3,7 +3,7 @@
# Date created: 03 Oct 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.4 1997/12/24 01:21:31 alex Exp $
+# $Id: Makefile,v 1.5 1998/09/27 20:11:17 steve Exp $
#
DISTNAME= plplot4p99j
@@ -16,15 +16,17 @@ MAINTAINER= tg@FreeBSD.ORG
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gcc=yes --with-double=yes
+.include <bsd.port.pre.mk>
+
post-patch:
@perl -pi.bak -e "s|/usr/local/plplot/lib|${PREFIX}/lib/plplot|g;" \
${WRKSRC}/src/plctrl.c
post-install:
- if [ "${PORTOBJFORMAT}" = "elf" ]; then \
- ${LN} -sf libplplotdX.so.4 ${PREFIX}/lib/libplplotdX.so; \
- else \
- ${LN} -sf libplplotdX.so.4.99 ${PREFIX}/lib/libplplotdX.so; \
- fi
+.if ${PORTOBJFORMAT} == "elf"
+ ${LN} -sf libplplotdX.so.4 ${PREFIX}/lib/libplplotdX.so
+.else
+ ${LN} -sf libplplotdX.so.4.99 ${PREFIX}/lib/libplplotdX.so
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>