aboutsummaryrefslogtreecommitdiffstats
path: root/math/primegen
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2017-03-29 10:45:49 +0800
committerdanfe <danfe@FreeBSD.org>2017-03-29 10:45:49 +0800
commit5ed4929adba9f0f7e379c4cd7a3270c451074596 (patch)
treeb59e839eb30006109070ebf7f2bc14d2a072966d /math/primegen
parentb32f707052e2875d194b07757abd0f83b006f88f (diff)
downloadfreebsd-ports-gnome-5ed4929adba9f0f7e379c4cd7a3270c451074596.tar.gz
freebsd-ports-gnome-5ed4929adba9f0f7e379c4cd7a3270c451074596.tar.zst
freebsd-ports-gnome-5ed4929adba9f0f7e379c4cd7a3270c451074596.zip
- Optimize away PROGRAM_FILES, HEADER_FILES, and LIB_FILES variables:
they contain one to two values and make things harder to understand; this allows to simplify PLIST_FILES setting and `do-install' target - Fix `post-patch' target: instead of sed(1)ing each and every file, and leaving lots of `*.bak' files behind, apply the fix where it is needed only (while here, simplify that regular expression as well) - Set correct ALL_TARGET instead blanking it; fix pkg-descr formatting
Diffstat (limited to 'math/primegen')
-rw-r--r--math/primegen/Makefile39
-rw-r--r--math/primegen/pkg-descr7
2 files changed, 15 insertions, 31 deletions
diff --git a/math/primegen/Makefile b/math/primegen/Makefile
index 1ae6ff52912e..759762127e76 100644
--- a/math/primegen/Makefile
+++ b/math/primegen/Makefile
@@ -9,28 +9,18 @@ MASTER_SITES= http://cr.yp.to/primegen/
MAINTAINER= ports@FreeBSD.org
COMMENT= Small, fast library to generate prime numbers in order
-ALL_TARGET=
+ALL_TARGET= default
-PROGRAM_FILES= primes primegaps
-HEADER_FILES= primegen.h
-LIB_FILES= libprimegen.a
-
-# programs
-PLIST_FILES+= ${PROGRAM_FILES:S,^,bin/,}
-
-# header files
-PLIST_FILES+= ${HEADER_FILES:S,^,include/,}
-
-# libraries
-PLIST_FILES+= ${LIB_FILES:S,^,lib/,}
-
-# man pages
-PLIST_FILES+= man/man1/primes.1.gz man/man1/primegaps.1.gz \
+PLIST_FILES= bin/primes bin/primegaps \
+ include/primegen.h \
+ lib/libprimegen.a \
+ man/man1/primes.1.gz \
+ man/man1/primegaps.1.gz \
man/man3/primegen.3.gz
post-patch:
- @${FIND} ${WRKSRC} -type f -exec \
- ${REINPLACE_CMD} -E -e 's!(primegen.a)!lib\1!' {} \;
+ @${REINPLACE_CMD} -e 's,primegen\.a,lib&,' ${WRKSRC}/Makefile \
+ ${WRKSRC}/TARGETS ${WRKSRC}/hier.c
do-configure:
@${ECHO_CMD} '${CC} ${CFLAGS} -fsigned-char -fPIC' > ${WRKSRC}/conf-cc
@@ -38,15 +28,10 @@ do-configure:
@${ECHO_CMD} '${PREFIX}' > ${WRKSRC}/conf-home
do-install:
-.for file in ${PROGRAM_FILES}
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
-.endfor
-.for file in ${HEADER_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/include
-.endfor
-.for file in ${LIB_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/lib
-.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/primes ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/primegaps ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/primegen.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/libprimegen.a ${STAGEDIR}${PREFIX}/lib
${INSTALL_MAN} ${WRKSRC}/primes.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/primegaps.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/primegen.3 ${STAGEDIR}${MAN3PREFIX}/man/man3
diff --git a/math/primegen/pkg-descr b/math/primegen/pkg-descr
index d681e3e21b2c..1f9c05d18967 100644
--- a/math/primegen/pkg-descr
+++ b/math/primegen/pkg-descr
@@ -1,7 +1,6 @@
-primegen is a small, fast library to generate prime numbers in
-order. It generates the 50847534 primes up to 1000000000 in just 8
-seconds on a Pentium II-350; it prints them in decimal in just 35
-seconds.
+primegen is a small, fast library to generate prime numbers in order.
+It generates the 50847534 primes up to 1000000000 in just 8 seconds
+on a Pentium II-350; it prints them in decimal in just 35 seconds.
primegen can generate primes up to 1000000000000000, although it
is not optimized for primes past 32 bits. It uses the Sieve of Atkin