aboutsummaryrefslogtreecommitdiffstats
path: root/math/proofgeneral
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-09-15 08:47:17 +0800
committerbarner <barner@FreeBSD.org>2005-09-15 08:47:17 +0800
commitfb02a29229b3a87a4a09982c7c22b61fbc8596bb (patch)
tree7b305c730533e567e33754269605270a95928c79 /math/proofgeneral
parent1a9326ec708f0cf5b9fe7404b17e160530811872 (diff)
downloadfreebsd-ports-gnome-fb02a29229b3a87a4a09982c7c22b61fbc8596bb.tar.gz
freebsd-ports-gnome-fb02a29229b3a87a4a09982c7c22b61fbc8596bb.tar.zst
freebsd-ports-gnome-fb02a29229b3a87a4a09982c7c22b61fbc8596bb.zip
Fix build:
- Use any installed version of [x]emacs - If there's no emacs at all, fall back to xemacs21-mule - files/patch-isa_isabelle-system.el: Avoid interactive prompt if building with GNU emacs. Submitted by: barner, maintainer (partly) Approved by: Timothy Bourke <timbob@bigpond.com> (maintainer) Reported by: kris via pointyhat
Diffstat (limited to 'math/proofgeneral')
-rw-r--r--math/proofgeneral/Makefile29
-rw-r--r--math/proofgeneral/files/patch-isa_isabelle-system.el13
2 files changed, 35 insertions, 7 deletions
diff --git a/math/proofgeneral/Makefile b/math/proofgeneral/Makefile
index 89dd1e6fe31a..9a55b711c485 100644
--- a/math/proofgeneral/Makefile
+++ b/math/proofgeneral/Makefile
@@ -17,19 +17,34 @@ DISTNAME= ProofGeneral-3.5
MAINTAINER= timbob@bigpond.com
COMMENT= A generic interface for proof assistants
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
- ${EMACS_NAME}:${EMACS_PORTSDIR}
+PKGNAMESUFFIX+= -${EMACS_NAME}
-.if exists(${LOCALBASE}/bin/xemacs)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages:${PORTSDIR}/editors/xemacs-packages
+BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
RUN_DEPENDS+= ${LOCALBASE}/share/applications/.keep_me:${PORTSDIR}/misc/kdehier
-.endif
-.if exists(${LOCALBASE}/bin/xemacs) || !exists(${LOCALBASE}/bin/emacs)
+.include <bsd.port.pre.mk>
+
+#
+# Unless EMACS_PORT_NAME is overriden by the user,
+# use any installed version of [X]Emacs.
+#
+# If there is none installed, use xemacs21-mule.
+#
+.if !defined(EMACS_PORT_NAME)
+.if !exists(${LOCALBASE}/bin/emacs)
EMACS_PORT_NAME=xemacs21-mule
+
+# xemacs21-mule does not depend on xemacs-packages, so add a dependency here
+BUILD_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/lisp/xlib/xlib-xlib.el:${PORTSDIR}/editors/xemacs-packages
+RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/lisp/xlib/xlib-xlib.el:${PORTSDIR}/editors/xemacs-packages
.else
EMACS_PORT_NAME=emacs21
.endif
+.endif
+
+# Needed for proper build- and run-time [x]xemacs dependencies,
+# and the definition of EMACS_NAME and EMACS_SITE_LISPDIR
+.include "${PORTSDIR}/Mk/bsd.emacs.mk"
MAKE_ARGS+= EMACS_NAME=${EMACS_NAME} EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
USE_GMAKE= yes
@@ -73,4 +88,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/proofgeneral/files/patch-isa_isabelle-system.el b/math/proofgeneral/files/patch-isa_isabelle-system.el
new file mode 100644
index 000000000000..e42f6b7b7c28
--- /dev/null
+++ b/math/proofgeneral/files/patch-isa_isabelle-system.el
@@ -0,0 +1,13 @@
+--- isa/isabelle-system.el.orig Thu Sep 8 12:43:45 2005
++++ isa/isabelle-system.el Thu Sep 8 12:45:12 2005
+@@ -73,10 +73,6 @@
+ with full path."
+ (interactive)
+ (unless (or isatool-not-found (file-executable-p isa-isatool-command))
+- (setq isa-isatool-command
+- (read-file-name
+- "Please give the full path to `isatool' (RET if you don't have it): "
+- nil nil nil))
+ (if (not (file-executable-p isa-isatool-command))
+ (progn
+ (setq isatool-not-found t)