aboutsummaryrefslogtreecommitdiffstats
path: root/math/pspp/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-14 17:12:01 +0800
committermiwi <miwi@FreeBSD.org>2009-01-14 17:12:01 +0800
commitc6d1a4dbb4d364d6a235bd791467e4bda4f5fd86 (patch)
treeb538a2112192251a22c69a5212e5c4c768f16b9f /math/pspp/Makefile
parent60884128f0fc8399a9115422353e9a37c7d68e0c (diff)
downloadfreebsd-ports-gnome-c6d1a4dbb4d364d6a235bd791467e4bda4f5fd86.tar.gz
freebsd-ports-gnome-c6d1a4dbb4d364d6a235bd791467e4bda4f5fd86.tar.zst
freebsd-ports-gnome-c6d1a4dbb4d364d6a235bd791467e4bda4f5fd86.zip
- Install developer tools if WITH_GUI is enabled
- Fix handling empty directory PR: 130469 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'math/pspp/Makefile')
-rw-r--r--math/pspp/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index c6671b1cb81b..db9aa794295c 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pspp
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= GNU
@@ -19,7 +20,7 @@ LIB_DEPENDS= plot.4:${PORTSDIR}/graphics/plotutils \
OPTIONS= GUI "Build the PSPPIRE gui" off \
PGSQL "Compile in PostgreSQL capability" off
-USE_GNOME= gnometarget libxml2
+USE_GNOME= libxml2
USE_PERL5_BUILD=yes
USE_ICONV= yes
USE_GMAKE= yes
@@ -45,6 +46,7 @@ PLIST_SUB+= NLS=""
LIB_DEPENDS+= gladeui-1:${PORTSDIR}/devel/glade3
RUN_DEPENDS+= yelp:${PORTSDIR}/x11/yelp
USE_GNOME+= libglade2
+CONFIGURE_ARGS+= --with-gui-tools
PLIST_SUB+= GUI=""
.else
CONFIGURE_ARGS+= --without-gui
@@ -57,4 +59,11 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --without-libpq
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/^install-exec-am:/s|install-exec-local||' \
+ ${WRKSRC}/gl/Makefile.in
+
+post-install:
+ @${TOUCH} ${PREFIX}/lib/pspp/.keep_me
+
.include <bsd.port.post.mk>