aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-fiat/Makefile
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-04-15 03:23:25 +0800
committerjgh <jgh@FreeBSD.org>2012-04-15 03:23:25 +0800
commit1e6fde7b19a3e52d6425e2dfcb8baeb43632a0f7 (patch)
tree947a421dd1c9c47e84529fe1e515f22a64779b71 /math/py-fiat/Makefile
parentb20df2e7fdbb9cfc2ce6e3a1e202bb9851059d54 (diff)
downloadfreebsd-ports-gnome-1e6fde7b19a3e52d6425e2dfcb8baeb43632a0f7.tar.gz
freebsd-ports-gnome-1e6fde7b19a3e52d6425e2dfcb8baeb43632a0f7.tar.zst
freebsd-ports-gnome-1e6fde7b19a3e52d6425e2dfcb8baeb43632a0f7.zip
Add new port: math/py-fiat
The FInite element Automatic Tabulator FIAT supports generation of arbitrary order instances of the Lagrange elements on lines, triangles, and tetrahedra. WWW: https://launchpad.net/fiat PR: ports/166910 Submitted by: jwbacon@tds.net
Diffstat (limited to 'math/py-fiat/Makefile')
-rw-r--r--math/py-fiat/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/py-fiat/Makefile b/math/py-fiat/Makefile
new file mode 100644
index 000000000000..25d85b3b5b1c
--- /dev/null
+++ b/math/py-fiat/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-fiat
+# Date created: 13 April 2012
+# Whom: Jason Bacon <jwbacon@tds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fiat
+PORTVERSION= 1.0.0
+CATEGORIES= math python
+MASTER_SITES= https://launchpad.net/${PORTNAME}/1.0.x/${PORTVERSION}/+download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= FInite element Automatic Tabulator
+
+LICENSE= LGPL3
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= FIAT
+
+FETCH_ARGS= -F
+
+.include <bsd.port.mk>