aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-gnuplot/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-07-04 00:26:56 +0800
committersobomax <sobomax@FreeBSD.org>2000-07-04 00:26:56 +0800
commit61af2a902853865742ff428600978681f7fa7ee7 (patch)
treecd6e126a3c9fc8c01d0fc2e786fca24bc67362a6 /math/py-gnuplot/Makefile
parent8895ad91c2df9ebaa8a70e90d3d635dc2d02ff8d (diff)
downloadfreebsd-ports-gnome-61af2a902853865742ff428600978681f7fa7ee7.tar.gz
freebsd-ports-gnome-61af2a902853865742ff428600978681f7fa7ee7.tar.zst
freebsd-ports-gnome-61af2a902853865742ff428600978681f7fa7ee7.zip
New port of py-gnuplot - a python interface to the popular gnuplot data
plotting package.
Diffstat (limited to 'math/py-gnuplot/Makefile')
-rw-r--r--math/py-gnuplot/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/py-gnuplot/Makefile b/math/py-gnuplot/Makefile
new file mode 100644
index 000000000000..94bd8b6257c5
--- /dev/null
+++ b/math/py-gnuplot/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-gnuplot
+# Date created: 3 July 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= py-gnuplot
+PORTVERSION= 1.4
+CATEGORIES= math python
+MASTER_SITES= http://monsoon.harvard.edu/~mhagger/Gnuplot/
+DISTNAME= Gnuplot-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python \
+ gnuplot:${PORTSDIR}/math/gnuplot \
+ ${LOCALBASE}/lib/python1.5/site-packages/Numeric/_numpy.so:${PORTSDIR}/math/numpy
+
+do-build:
+ @${LOCALBASE}/bin/python \
+ ${LOCALBASE}/lib/python1.5/compileall.py ${WRKSRC}
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/python1.5/site-packages/Gnuplot
+ ${INSTALL_DATA} ${WRKSRC}/*.py? \
+ ${PREFIX}/lib/python1.5/site-packages/Gnuplot
+
+.include <bsd.port.mk>