aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-graphtool
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-06-07 19:12:24 +0800
committerwxs <wxs@FreeBSD.org>2011-06-07 19:12:24 +0800
commitc2aac530400139589b5693d9d71b3ea996170ed1 (patch)
treef2d4d30bc8a0bfe1e9498075470f8f185fb7a638 /math/py-graphtool
parent5c969bd4c4a6d1ca99c0ead986a7e0e751e31339 (diff)
downloadfreebsd-ports-gnome-c2aac530400139589b5693d9d71b3ea996170ed1.tar.gz
freebsd-ports-gnome-c2aac530400139589b5693d9d71b3ea996170ed1.tar.zst
freebsd-ports-gnome-c2aac530400139589b5693d9d71b3ea996170ed1.zip
- Fix build.
Noticed by: pav@ (via pointyhat) Pointyhat to: me
Diffstat (limited to 'math/py-graphtool')
-rw-r--r--math/py-graphtool/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/math/py-graphtool/Makefile b/math/py-graphtool/Makefile
index 5743e664a107..790ef63b8fb1 100644
--- a/math/py-graphtool/Makefile
+++ b/math/py-graphtool/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= dikshie@sfc.wide.ad.jp
COMMENT= Python module for complex network based on C++
BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.8.0:${PORTSDIR}/science/py-scipy
LIB_DEPENDS= boost_python.4:${PORTSDIR}/devel/boost-python-libs \
boost_graph.4:${PORTSDIR}/devel/boost-libs \
CGAL.5:${PORTSDIR}/math/cgal
@@ -26,4 +27,6 @@ USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= PYTHON_VERSION=${PYTHON_VER}
+
.include <bsd.port.mk>