aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-keras
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-06-23 01:14:44 +0800
committerpawel <pawel@FreeBSD.org>2016-06-23 01:14:44 +0800
commit1f70faebc6e5b51d0a70e0638567df626b064fde (patch)
tree9a5a32d036e84ee669d064ac2fd154cd8f3a7614 /math/py-keras
parentc1fd91fb02649e7dce7291f49b8520b6e5638487 (diff)
downloadfreebsd-ports-gnome-1f70faebc6e5b51d0a70e0638567df626b064fde.tar.gz
freebsd-ports-gnome-1f70faebc6e5b51d0a70e0638567df626b064fde.tar.zst
freebsd-ports-gnome-1f70faebc6e5b51d0a70e0638567df626b064fde.zip
Deep Learning library for Python. Convnets, recurrent neural networks, and
more. Runs on Theano and TensorFlow. WWW: http://keras.io/ PR: 210119 Submitted by: Neel Chauhan <neel@neelc.org>
Diffstat (limited to 'math/py-keras')
-rw-r--r--math/py-keras/Makefile24
-rw-r--r--math/py-keras/distinfo3
-rw-r--r--math/py-keras/pkg-descr4
3 files changed, 31 insertions, 0 deletions
diff --git a/math/py-keras/Makefile b/math/py-keras/Makefile
new file mode 100644
index 000000000000..f31d825ad531
--- /dev/null
+++ b/math/py-keras/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= keras
+PORTVERSION= 1.0.4
+CATEGORIES= math
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= neel@neelc.org
+COMMENT= Deep Learning library for Python
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}theano>=0.8.0:math/py-theano \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six \
+
+USE_GITHUB= yes
+GH_ACCOUNT= fchollet
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-keras/distinfo b/math/py-keras/distinfo
new file mode 100644
index 000000000000..46f5a41773a0
--- /dev/null
+++ b/math/py-keras/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465323531
+SHA256 (fchollet-keras-1.0.4_GH0.tar.gz) = 64abdd31dabb1abf704b922412e190fde8fe6777d1ff6396e48e75ff51024364
+SIZE (fchollet-keras-1.0.4_GH0.tar.gz) = 211314
diff --git a/math/py-keras/pkg-descr b/math/py-keras/pkg-descr
new file mode 100644
index 000000000000..2b55073b05fd
--- /dev/null
+++ b/math/py-keras/pkg-descr
@@ -0,0 +1,4 @@
+Deep Learning library for Python. Convnets, recurrent neural networks, and
+more. Runs on Theano and TensorFlow.
+
+WWW: http://keras.io/