aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-matplotlib
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2016-02-15 08:56:30 +0800
committerolgeni <olgeni@FreeBSD.org>2016-02-15 08:56:30 +0800
commitbd9dc44cc4160909d4c6eba667a137cf7e6fd239 (patch)
tree5b13c6c0288ae416909f4c6247128c7c5685e918 /math/py-matplotlib
parent62f6c25f4ac18aca3b6b40015f357c5d6dacfedd (diff)
downloadfreebsd-ports-gnome-bd9dc44cc4160909d4c6eba667a137cf7e6fd239.tar.gz
freebsd-ports-gnome-bd9dc44cc4160909d4c6eba667a137cf7e6fd239.tar.zst
freebsd-ports-gnome-bd9dc44cc4160909d4c6eba667a137cf7e6fd239.zip
Make the cairo and gdkpixbuf2 dependencies conditional on
GTKBACKEND and GTKAGGBACKEND. This change restores headless support. Approved by: maintainer (by mail)
Diffstat (limited to 'math/py-matplotlib')
-rw-r--r--math/py-matplotlib/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 19ae4af00541..0ae5f729bcb0 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -26,7 +26,6 @@ RUN_DEPENDS= ${PYNUMPY} \
USES= compiler:c++11-lib gettext pkgconfig python shebangfix uniquefiles:dirs
USE_PYTHON= autoplist distutils
-USE_GNOME= cairo gdkpixbuf2
CFLAGS+= -I${LOCALBASE}/include
OPTIONS_DEFINE= EXAMPLES GTKBACKEND GTKAGGBACKEND QT4AGGBACKEND \
@@ -36,9 +35,9 @@ OPTIONS_SUB= yes
GTKBACKEND_DESC= GTK backend support
GTKBACKEND_VARS= GTK_BACKEND=True
GTKBACKEND_VARS_OFF= GTK_BACKEND=False
-GTKBACKEND_USE= GNOME=gtk20,pygtk2
+GTKBACKEND_USE= GNOME=gtk20,pygtk2,cairo,gdkpixbuf2
GTKAGGBACKEND_DESC= GTKAgg backend support
-GTKAGGBACKEND_USE= GNOME=gtk20,pygtk2
+GTKAGGBACKEND_USE= GNOME=gtk20,pygtk2,cairo,gdkpixbuf2
GTKAGGBACKEND_VARS= GTKAGG_BACKEND=True
GTKAGGBACKEND_VARS_OFF= GTKAGG_BACKEND=False
QT4AGGBACKEND_DESC= Qt4Agg backend support