aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-matplotlib
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-05 22:28:24 +0800
committerbapt <bapt@FreeBSD.org>2013-06-05 22:28:24 +0800
commit122a00ba123452ea8cb0090e8eeb94a990d0ee61 (patch)
tree45656b48f28443aa5b44b383579ab66f46caf3c6 /math/py-matplotlib
parent0302be1a4845d3ce727640c3cf2f29297dbc627e (diff)
downloadfreebsd-ports-gnome-122a00ba123452ea8cb0090e8eeb94a990d0ee61.tar.gz
freebsd-ports-gnome-122a00ba123452ea8cb0090e8eeb94a990d0ee61.tar.zst
freebsd-ports-gnome-122a00ba123452ea8cb0090e8eeb94a990d0ee61.zip
Convert to new options framework
Diffstat (limited to 'math/py-matplotlib')
-rw-r--r--math/py-matplotlib/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index a4cc7132d818..9d7ff2171d39 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -23,26 +23,28 @@ USE_PYTHON= yes
USE_PYDISTUTILS=yes
CFLAGS+= -I${LOCALBASE}/include
-OPTIONS= GTKBACKEND "GTK backend support" ON \
- GTKAGGBACKEND "GTKAgg backend support" ON \
- TKAGGBACKEND "TKAgg backend support" ON \
- WXAGGBACKEND "WXAgg backend support" OFF
+OPTIONS_DEFINE= GTKBACKEND GTKAGGBACKEND TKAGGBACKEND WXAGGBACKEND
+OPTIONS_DEFAULT= GTKBACKEND GTKAGGBACKEND TKAGGBACKEND
+GTKBACKEND_DESC= GTK backend support
+GTKAGGBACKEND_DESC= GTKAgg backend support
+TKAGGBACKEND_DESC= TKAgg backend support
+WXAGGBACKEND_DESC= WXAgg backend support
UNIQUENAME= ${PORTNAME}
.include <bsd.port.options.mk>
.if defined(PACKAGE_BUILDING) && \
- (defined(WITH_GTKBACKEND) || defined(WITH_GTKAGGBACKEND) || \
- defined(WITH_TKAGGBACKEND) || defined(WITH_WXAGGBACKEND))
+ ( ${PORT_OPTIONS:MGTKBACKEND} || ${PORT_OPTIONS:MGTKAGGBACKEND} || \
+ ${PORT_OPTIONS:MTKAGGBACKEND} || ${PORT_OPTIONS:MWXAGGBACKEND})
BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
-.if defined(WITH_GTKBACKEND) || defined(WITH_GTKAGGBACKEND)
+.if ${PORT_OPTIONS:MGTKBACKEND} || ${PORT_OPTIONS:MGTKAGGBACKEND}
USE_GNOME= gtk20 pygtk2
.endif
-.if defined(WITH_GTKBACKEND) && !defined(WITHOUT_GTKBACKEND)
+.if ${PORT_OPTIONS:MGTKBACKEND}
GTK_BACKEND= True
PLIST_SUB+= GTKBACKEND=""
@@ -52,7 +54,7 @@ GTK_BACKEND= False
PLIST_SUB+= GTKBACKEND="@comment "
.endif
-.if defined(WITH_GTKAGGBACKEND)
+.if ${PORT_OPTIONS:MGTKAGGBACKEND}
GTKAGG_BACKEND= True
PLIST_SUB+= GTKAGGBACKEND=""
@@ -62,7 +64,7 @@ GTKAGG_BACKEND= False
PLIST_SUB+= GTKAGGBACKEND="@comment "
.endif
-.if defined(WITH_TKAGGBACKEND)
+.if ${PORT_OPTIONS:MTKAGGBACKEND}
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
@@ -78,7 +80,7 @@ TKAGG_BACKEND= False
PLIST_SUB+= TKAGGBACKEND="@comment "
.endif
-.if defined(WITH_WXAGGBACKEND)
+.if ${PORT_OPTIONS:MWXAGGBACKEND}
USE_WX= 2.8+
WX_COMPS= python:lib
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
@@ -108,7 +110,7 @@ post-patch:
-e 's|%%WXAGG_BACKEND%%|${WXAGG_BACKEND}|g' \
${WRKSRC}/setup.cfg
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
post-install:
@${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}