aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-networkx
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2016-01-05 16:42:05 +0800
committerrm <rm@FreeBSD.org>2016-01-05 16:42:05 +0800
commitebe8e28a8c98251e7896bf95f3921936ea5e087e (patch)
treeb8e131b158929fc06f0b5556bf0f763985c0ef67 /math/py-networkx
parent5eea9454aa2dc7759a4c8ac4f093965bdf6a7da2 (diff)
downloadfreebsd-ports-gnome-ebe8e28a8c98251e7896bf95f3921936ea5e087e.tar.gz
freebsd-ports-gnome-ebe8e28a8c98251e7896bf95f3921936ea5e087e.tar.zst
freebsd-ports-gnome-ebe8e28a8c98251e7896bf95f3921936ea5e087e.zip
math/py-networkx: let it build with python3
Drop the python version limit, by asking user to uncheck some options, that will not work with python3 for now. PR: 204594 Submitted by: John W. O'Brien <john@saltant.com> Approved by: dikshie@sfc.wide.ad.jp (maintainer)
Diffstat (limited to 'math/py-networkx')
-rw-r--r--math/py-networkx/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/math/py-networkx/Makefile b/math/py-networkx/Makefile
index 065a88d2c419..ad8e136949bd 100644
--- a/math/py-networkx/Makefile
+++ b/math/py-networkx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= networkx
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= http://networkx.lanl.gov/download/networkx/ \
CHEESESHOP
@@ -19,7 +20,7 @@ RUN_DEPENDS:= ${PYTHON_PKGNAMEPREFIX}decorator>=3.4.0:${PORTSDIR}/devel/py-decor
# ${PYTHON_PKGNAMEPREFIX}docutils>=0.12:${PORTSDIR}/textproc/py-docutils
NO_ARCH= yes
-USES= python:2 shebangfix
+USES= python shebangfix
USE_PYTHON= autoplist concurrent distutils
PLIST_SUB+= PYTHON_MAJOR_VER=${PYTHON_MAJOR_VER}
@@ -46,10 +47,16 @@ GRAPHVIZ_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}graphviz>=1.2:${PORTSDIR}/graphics/
YAML_DESC= Reading and writing YAML files
YAML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=0:${PORTSDIR}/devel/py-yaml
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 3000 && (${PORT_OPTIONS:MMPL} || ${PORT_OPTIONS:MGRAPHVIZ})
+BROKEN= Neither math/py-matplotlib nor graphics/py-graphviz support Python 3.x yet. Please disable both the MPL and GRAPHVIZ options
+.endif
+
PORTEXAMPLES= *
post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>