aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-numpy
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2008-04-17 22:49:29 +0800
committerlwhsu <lwhsu@FreeBSD.org>2008-04-17 22:49:29 +0800
commit2d551e9a227e682c702e18f9643b5d0e356804b6 (patch)
tree64a300cc2855a4de92c56d30146434af13464e65 /math/py-numpy
parent4644aaad755ffd2eb340fb7f0cb0da20a98b8787 (diff)
downloadfreebsd-ports-gnome-2d551e9a227e682c702e18f9643b5d0e356804b6.tar.gz
freebsd-ports-gnome-2d551e9a227e682c702e18f9643b5d0e356804b6.tar.zst
freebsd-ports-gnome-2d551e9a227e682c702e18f9643b5d0e356804b6.zip
- Add lang/gcc42 into RUN_DEPENDS
- Remove ${PYTHON_REL} < 200 old stuff - Remove definitions that already include in bsd.gcc.mk Approved by: maintainer via IRC
Diffstat (limited to 'math/py-numpy')
-rw-r--r--math/py-numpy/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index 65102f041544..36c759248817 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= numpy
PORTVERSION= 1.0.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= math python
MASTER_SITES= http://numpy.scipy.org/:doc \
@@ -20,6 +21,8 @@ EXTRACT_ONLY= numpy-${PORTVERSION:S/r/rc/}${EXTRACT_SUFX}
MAINTAINER= llwang@infor.org
COMMENT= The New Numeric Extension to Python
+RUN_DEPENDS= gcc42:${PORTSDIR}/lang/gcc42
+
OPTIONS= ATLAS "Use optimized blas library" Off
USE_FORTRAN= yes
@@ -42,18 +45,9 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack \
blas.2:${PORTSDIR}/math/blas
.endif
-pre-fetch:
-.if ${PYTHON_REL} < 200
- @${ECHO} "Py-numpy doesn't work with Python versions < 2.0."
- @${ECHO} "Please use the py-numeric17 port for these."
- @${FALSE}
-.endif
-
post-extract:
@${CP} ${DISTDIR}/numpy.pdf ${WRKDIR}
-FC= gfortran42
-F77= gfortran42
GCCLIBDIR= `${FC} -print-file-name=libgfortran.so|${SED} -e s/libgfortran.so//`
post-patch:
.ifdef WITH_ATLAS