aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-secp256k1/Makefile
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-09-20 09:22:59 +0800
committeryuri <yuri@FreeBSD.org>2018-09-20 09:22:59 +0800
commitc00d211a361fc04c2071c6455d26bcae4ff99c04 (patch)
treebbd108d138d629f3493a02bfce41312bd95e7bf7 /math/py-secp256k1/Makefile
parenta41e02ac4a5bb39cb489591d3018cdcf07498105 (diff)
downloadfreebsd-ports-gnome-c00d211a361fc04c2071c6455d26bcae4ff99c04.tar.gz
freebsd-ports-gnome-c00d211a361fc04c2071c6455d26bcae4ff99c04.tar.zst
freebsd-ports-gnome-c00d211a361fc04c2071c6455d26bcae4ff99c04.zip
math/py-secp256k1: Add the missing do-test target
Approved by: portmgr blanket
Diffstat (limited to 'math/py-secp256k1/Makefile')
-rw-r--r--math/py-secp256k1/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/math/py-secp256k1/Makefile b/math/py-secp256k1/Makefile
index 6c3190350e33..fe0c68534ec5 100644
--- a/math/py-secp256k1/Makefile
+++ b/math/py-secp256k1/Makefile
@@ -13,10 +13,13 @@ COMMENT= FFI bindings to libsecp256k1
LICENSE= MIT
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.8.0:devel/py-cffi@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=2.11.1:devel/py-pytest-runner@${PY_FLAVOR}
LIB_DEPENDS= libsecp256k1.so:math/secp256k1
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=2.11.1:devel/py-pytest-runner@${PY_FLAVOR}
USES= localbase python pkgconfig
USE_PYTHON= autoplist distutils
+do-test: # some tests fail: https://github.com/ludbb/secp256k1-py/issues/31
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m test
+
.include <bsd.port.mk>