aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-symeig
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-09-28 02:50:12 +0800
committermiwi <miwi@FreeBSD.org>2008-09-28 02:50:12 +0800
commit8530e17dc60c4c3d6df7576df37d3e4bce49000a (patch)
tree534d0280d4a48a87bf00344b170e305317e1b873 /math/py-symeig
parent54b2c503dfe1367a17c98193138d2da6d984c8b6 (diff)
downloadfreebsd-ports-gnome-8530e17dc60c4c3d6df7576df37d3e4bce49000a.tar.gz
freebsd-ports-gnome-8530e17dc60c4c3d6df7576df37d3e4bce49000a.tar.zst
freebsd-ports-gnome-8530e17dc60c4c3d6df7576df37d3e4bce49000a.zip
The symeig module contains a Python wrapper for the LAPACK functions to
solve the standard and generalized eigenvalue problems for symmetric (hermitian) positive definite matrices. Those specialized algorithms give an important speed-up with respect to the generic LAPACK eigenvalue problem solver used by NumPy (linalg.eig and linalg.eigh). WWW: http://mdp-toolkit.sourceforge.net/symeig.html PR: ports/127336 Submitted by: Li-Lun Wang <llwang at infor.org>
Diffstat (limited to 'math/py-symeig')
-rw-r--r--math/py-symeig/Makefile40
-rw-r--r--math/py-symeig/distinfo3
-rw-r--r--math/py-symeig/pkg-descr7
-rw-r--r--math/py-symeig/pkg-plist21
4 files changed, 71 insertions, 0 deletions
diff --git a/math/py-symeig/Makefile b/math/py-symeig/Makefile
new file mode 100644
index 000000000000..83bb8b45b05f
--- /dev/null
+++ b/math/py-symeig/Makefile
@@ -0,0 +1,40 @@
+# Ports collection makefile for: Symeig
+# Date created: September 10, 2008
+# Whom: Li-Lun Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= symeig
+PORTVERSION= 1.4
+CATEGORIES= math python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mdp-toolkit
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= llwang@infor.org
+COMMENT= Symmetrical eigenvalue routines for NumPy
+
+BUILD_DEPENDS+= ${PYNUMPY}
+RUN_DEPENDS+= ${PYNUMPY}
+
+LATEST_LINK= py-${PORTNAME}
+OPTIONSFILE= ${PORT_DBDIR}/py-numpy/options
+
+USE_FORTRAN= yes
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+OPTIONS= ATLAS "Use optimized blas library" OFF
+
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+.if !exists(${LOCALBASE}/lib/libalapack.a)
+IGNORE= atlas needs to be built with WITH_STATICLIB for scipy to function properly
+.endif
+.else
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack \
+ blas.2:${PORTSDIR}/math/blas
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/py-symeig/distinfo b/math/py-symeig/distinfo
new file mode 100644
index 000000000000..e59626e1ed2c
--- /dev/null
+++ b/math/py-symeig/distinfo
@@ -0,0 +1,3 @@
+MD5 (symeig-1.4.tar.gz) = bff69c8720ea478477b56d600bc07314
+SHA256 (symeig-1.4.tar.gz) = 999556e99b03c3f98ef81ccf420ada1ba25c447c7a2739be4f44b54d5ac0f393
+SIZE (symeig-1.4.tar.gz) = 31109
diff --git a/math/py-symeig/pkg-descr b/math/py-symeig/pkg-descr
new file mode 100644
index 000000000000..4efba5f6cd3d
--- /dev/null
+++ b/math/py-symeig/pkg-descr
@@ -0,0 +1,7 @@
+The symeig module contains a Python wrapper for the LAPACK functions to
+solve the standard and generalized eigenvalue problems for symmetric
+(hermitian) positive definite matrices. Those specialized algorithms give
+an important speed-up with respect to the generic LAPACK eigenvalue
+problem solver used by NumPy (linalg.eig and linalg.eigh).
+
+WWW: http://mdp-toolkit.sourceforge.net/symeig.html
diff --git a/math/py-symeig/pkg-plist b/math/py-symeig/pkg-plist
new file mode 100644
index 000000000000..37b7642a8951
--- /dev/null
+++ b/math/py-symeig/pkg-plist
@@ -0,0 +1,21 @@
+%%PYTHON_SITELIBDIR%%/symeig/__init__.py
+%%PYTHON_SITELIBDIR%%/symeig/__init__.pyc
+%%PYTHON_SITELIBDIR%%/symeig/__init__.pyo
+%%PYTHON_SITELIBDIR%%/symeig/froutines.so
+%%PYTHON_SITELIBDIR%%/symeig/symeig.py
+%%PYTHON_SITELIBDIR%%/symeig/symeig.pyc
+%%PYTHON_SITELIBDIR%%/symeig/symeig.pyo
+%%PYTHON_SITELIBDIR%%/symeig/test/__init__.py
+%%PYTHON_SITELIBDIR%%/symeig/test/__init__.pyc
+%%PYTHON_SITELIBDIR%%/symeig/test/__init__.pyo
+%%PYTHON_SITELIBDIR%%/symeig/test/benchmark_symeig.py
+%%PYTHON_SITELIBDIR%%/symeig/test/benchmark_symeig.pyc
+%%PYTHON_SITELIBDIR%%/symeig/test/benchmark_symeig.pyo
+%%PYTHON_SITELIBDIR%%/symeig/test/test_symeig.py
+%%PYTHON_SITELIBDIR%%/symeig/test/test_symeig.pyc
+%%PYTHON_SITELIBDIR%%/symeig/test/test_symeig.pyo
+%%PYTHON_SITELIBDIR%%/symeig/test/testing_tools.py
+%%PYTHON_SITELIBDIR%%/symeig/test/testing_tools.pyc
+%%PYTHON_SITELIBDIR%%/symeig/test/testing_tools.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/symeig/test
+@dirrm %%PYTHON_SITELIBDIR%%/symeig