aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-theano
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2015-03-06 17:47:51 +0800
committerdemon <demon@FreeBSD.org>2015-03-06 17:47:51 +0800
commite92dc0302964a01e4848a7165c6d8d5dd318a129 (patch)
tree9afa17bcc65e9e44479becdcb7a817c8e11aa43a /math/py-theano
parent953c92ec7a788b353fc2d56402262332773562b1 (diff)
downloadfreebsd-ports-gnome-e92dc0302964a01e4848a7165c6d8d5dd318a129.tar.gz
freebsd-ports-gnome-e92dc0302964a01e4848a7165c6d8d5dd318a129.tar.zst
freebsd-ports-gnome-e92dc0302964a01e4848a7165c6d8d5dd318a129.zip
New port: Theano.
Theano is a Python library that allows you to define, optimize, and evaluate mathematical expressions involving multi-dimensional arrays efficiently. http://deeplearning.net/software/theano/
Diffstat (limited to 'math/py-theano')
-rw-r--r--math/py-theano/Makefile21
-rw-r--r--math/py-theano/distinfo2
-rw-r--r--math/py-theano/pkg-descr5
3 files changed, 28 insertions, 0 deletions
diff --git a/math/py-theano/Makefile b/math/py-theano/Makefile
new file mode 100644
index 000000000000..04e0ac85e63d
--- /dev/null
+++ b/math/py-theano/Makefile
@@ -0,0 +1,21 @@
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= theano
+PORTVERSION= 0.6.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+MASTER_SITE_SUBDIR=source/T/Theano
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Theano-${PORTVERSION}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Optimizing compiler for evaluating math expressions on CPUs and GPUs
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.8.0:${PORTSDIR}/science/py-scipy
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/math/py-theano/distinfo b/math/py-theano/distinfo
new file mode 100644
index 000000000000..0a10b9cf5b76
--- /dev/null
+++ b/math/py-theano/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Theano-0.6.0.tar.gz) = aaa75f9a9b7bf50f09ddcc01fb993cf47513179d0a7bee3d96bfeebd66e76083
+SIZE (Theano-0.6.0.tar.gz) = 1763756
diff --git a/math/py-theano/pkg-descr b/math/py-theano/pkg-descr
new file mode 100644
index 000000000000..df0316f27bc0
--- /dev/null
+++ b/math/py-theano/pkg-descr
@@ -0,0 +1,5 @@
+Theano is a Python library that allows you to define, optimize, and
+efficiently evaluate mathematical expressions involving multi-dimensional
+arrays. It is built on top of NumPy.
+
+WWW: http://deeplearning.net/software/theano/