aboutsummaryrefslogtreecommitdiffstats
path: root/math/pygist
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-09-06 20:19:39 +0800
committertg <tg@FreeBSD.org>2000-09-06 20:19:39 +0800
commit233a7031f15eacf0b9b6ba8069bca68c211750d2 (patch)
tree974deb952ce167fb4aa4d31e8d881d1e557c5e89 /math/pygist
parent506bf3ac21a6cbe74f43a0c668d57576f035906f (diff)
downloadfreebsd-ports-gnome-233a7031f15eacf0b9b6ba8069bca68c211750d2.tar.gz
freebsd-ports-gnome-233a7031f15eacf0b9b6ba8069bca68c211750d2.tar.zst
freebsd-ports-gnome-233a7031f15eacf0b9b6ba8069bca68c211750d2.zip
The RNG extension is now part of py-numeric.
Diffstat (limited to 'math/pygist')
-rw-r--r--math/pygist/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/math/pygist/Makefile b/math/pygist/Makefile
index ca1a7e02a619..5ab2489878a9 100644
--- a/math/pygist/Makefile
+++ b/math/pygist/Makefile
@@ -18,10 +18,10 @@ MAINTAINER= tg@FreeBSD.org
BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
${LOCALBASE}/lib/yorick/1.4/lib/libgist.a:${PORTSDIR}/lang/yorick \
${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy \
- ${RNGDIR}/Ranf.py:${PORTSDIR}/math/rng
+ ${RNGDIR}/RNG.so:${PORTSDIR}/math/numpy
RUN_DEPENDS= python:${PORTSDIR}/lang/python \
${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy \
- ${RNGDIR}/Ranf.py:${PORTSDIR}/math/rng
+ ${RNGDIR}/RNG.so:${PORTSDIR}/math/numpy
WRKSRC= ${WRKDIR}/${DISTNAME}/Graphics
CONFIGURE_ENV= PREFIX=${PREFIX}
@@ -34,6 +34,13 @@ NUMPYDIR= ${PYTHONSCRIPTDIR}/site-packages/Numeric
RNGDIR= ${PYTHONSCRIPTDIR}/site-packages/RNG
EXAMPLEDIR= ${PREFIX}/share/examples/PyGist
+post-patch:
+.for file in Gist3D/Demo/demo5.py Gist3D/Demo/gistmeshtest.py \
+ Narcisse/Demo/meshtest.py OOG/Demo/eztest.py \
+ OOG/Demo/surftest3d.py OOG/Demo/surftest4d.py
+ ${PERL} -pi -e 's/from Ranf import/from RNG import/' ${WRKSRC}/${file}
+.endfor
+
do-configure:
@(cd ${WRKSRC} && ${CONFIGURE_ENV} python makethis.py)