aboutsummaryrefslogtreecommitdiffstats
path: root/math/qwtplot3d-qt4
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-04-17 06:34:11 +0800
committermakc <makc@FreeBSD.org>2012-04-17 06:34:11 +0800
commitaa1923aba3eb008ec5717227e13ef932791cae01 (patch)
tree50a688af2a771ab98c4e11771814d018b335451c /math/qwtplot3d-qt4
parent45894d72194d6cd252b8ab18b6ce39f1f0550cbe (diff)
downloadfreebsd-ports-gnome-aa1923aba3eb008ec5717227e13ef932791cae01.tar.gz
freebsd-ports-gnome-aa1923aba3eb008ec5717227e13ef932791cae01.tar.zst
freebsd-ports-gnome-aa1923aba3eb008ec5717227e13ef932791cae01.zip
Fix build with upcoming Qt 4.8
Diffstat (limited to 'math/qwtplot3d-qt4')
-rw-r--r--math/qwtplot3d-qt4/Makefile1
-rw-r--r--math/qwtplot3d-qt4/files/patch-include__qwt3d_openglhelper.h10
-rw-r--r--math/qwtplot3d-qt4/files/patch-qwtplot3d.pro14
3 files changed, 22 insertions, 3 deletions
diff --git a/math/qwtplot3d-qt4/Makefile b/math/qwtplot3d-qt4/Makefile
index 7e3bf0821f14..5cef16ebdbf3 100644
--- a/math/qwtplot3d-qt4/Makefile
+++ b/math/qwtplot3d-qt4/Makefile
@@ -18,6 +18,7 @@ COMMENT= 3D plotting widgets for scientific data and math expressions
USE_QT_VER= 4
QT_COMPONENTS= gui moc_build qmake_build opengl
+USE_GL= glu
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
USE_DOS2UNIX= yes
diff --git a/math/qwtplot3d-qt4/files/patch-include__qwt3d_openglhelper.h b/math/qwtplot3d-qt4/files/patch-include__qwt3d_openglhelper.h
new file mode 100644
index 000000000000..d24e1eca0ac4
--- /dev/null
+++ b/math/qwtplot3d-qt4/files/patch-include__qwt3d_openglhelper.h
@@ -0,0 +1,10 @@
+--- ./include/qwt3d_openglhelper.h.orig 2012-04-16 21:57:23.639051666 +0000
++++ ./include/qwt3d_openglhelper.h 2012-04-16 21:57:23.713053060 +0000
+@@ -6,6 +6,7 @@
+ #include <qgl.h>
+ #else
+ #include <QtOpenGL/qgl.h>
++#include <GL/glu.h>
+ #endif
+
+ namespace Qwt3D
diff --git a/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro b/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro
index e2ef214a117b..6c363a30330c 100644
--- a/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro
+++ b/math/qwtplot3d-qt4/files/patch-qwtplot3d.pro
@@ -1,5 +1,5 @@
---- ./qwtplot3d.pro.orig Tue Jun 26 18:34:05 2007
-+++ ./qwtplot3d.pro Tue Jun 26 18:34:57 2007
+--- ./qwtplot3d.pro.orig 2012-04-16 21:57:23.562053805 +0000
++++ ./qwtplot3d.pro 2012-04-16 21:58:00.311051941 +0000
@@ -1,9 +1,9 @@
# pro file for building the makefile for qwtplot3d
#
@@ -12,7 +12,15 @@
MOC_DIR = tmp
OBJECTS_DIR = tmp
INCLUDEPATH = include
-@@ -21,7 +21,7 @@
+@@ -11,6 +11,7 @@
+ DESTDIR = lib
+ #DESTDIR = ../../../lib
+ QT += opengl
++unix:LIBS += -lGLU
+
+ win32:TEMPLATE = vclib
+ win32:CONFIG += dll exceptions
+@@ -21,7 +22,7 @@
win32:CONFIG -= zlib
linux-g++:TMAKE_CXXFLAGS += -fno-exceptions