aboutsummaryrefslogtreecommitdiffstats
path: root/math/rkward-kde4/Makefile
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-05-07 11:29:59 +0800
committerbf <bf@FreeBSD.org>2011-05-07 11:29:59 +0800
commit08b509ea5d7b06897b6cf810c6a58df5a1411d80 (patch)
tree132c0d6a9c4c0ad22c98048b414a6dec7421d1fa /math/rkward-kde4/Makefile
parent4ff30b9a7287ac0d0ea2e7e3e0899125ecab9c24 (diff)
downloadfreebsd-ports-gnome-08b509ea5d7b06897b6cf810c6a58df5a1411d80.tar.gz
freebsd-ports-gnome-08b509ea5d7b06897b6cf810c6a58df5a1411d80.tar.zst
freebsd-ports-gnome-08b509ea5d7b06897b6cf810c6a58df5a1411d80.zip
- update to 2.13.0
- switch to the bundled Rblas and Rlapack by default (this can be changed by setting BLAS and LAPACK) which favors correctness in some corner cases over a slight performance penalty; this will be revisited after the blas and lapack updates - replace the STATIC_LIBR option with a LIBR option (on by default): if on, libR.a and libR.so are installed, and R is linked to libR.so. Otherwise, R is static, and no libRs are installed. - remove the superfluous copy of libR.so in ${LOCALBASE}/lib [1] - enable the cairo and pango elements in the X11() graphics device by default, controlled by new PANGOCAIRO option - add a few small patches to dependent ports, bumping PORTREVISION where necessary PR: 153309 [1] Approved by: thierry (rkward*), wen (rpy*, R-cran-*)
Diffstat (limited to 'math/rkward-kde4/Makefile')
-rw-r--r--math/rkward-kde4/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/math/rkward-kde4/Makefile b/math/rkward-kde4/Makefile
index 4da0dc857bf5..c5c22521a47b 100644
--- a/math/rkward-kde4/Makefile
+++ b/math/rkward-kde4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rkward
PORTVERSION= 0.5.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/Current_Stable_Releases
PKGNAMESUFFIX= -kde4
@@ -15,8 +15,9 @@ PKGNAMESUFFIX= -kde4
MAINTAINER= thierry@FreeBSD.org
COMMENT= IDE/GUI for the R-project
-LIB_DEPENDS= R.0:${PORTSDIR}/math/R
-RUN_DEPENDS= seq2:${PORTSDIR}/misc/seq2
+BUILD_DEPENDS= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R
+RUN_DEPENDS= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R \
+ seq2:${PORTSDIR}/misc/seq2
LICENSE= GPLv2
@@ -64,13 +65,16 @@ pre-configure:
${REINPLACE_CMD} -e 's|ADD_SUBDIRECTORY(po)|#ADD_SUBDIRECTORY(po)|' \
${WRKSRC}/CMakeLists.txt
.endif
+ @(if [ ! -e ${LOCALBASE}/lib/R/lib/libR.so ] ; then \
+ ${ECHO_MSG} "==> ${PKGNAME} requires math/R to be built WITH_LIBR" ; \
+ exit 1; fi)
post-install:
${TOUCH} ${LOCALBASE}/lib/R/library/rkwardtests/doc/.empty
.if defined(MAINTAINER_MODE)
regression-test: install
- @${ECHO_MSG} "To pass the tests, somme CRAN packages like R2HTML"
+ @${ECHO_MSG} "To pass the tests, some CRAN packages like R2HTML"
@${ECHO_MSG} "must be installed."
(cd ${WRKSRC}/tests && make plugintests)
.endif