aboutsummaryrefslogtreecommitdiffstats
path: root/math/rngstreams
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-19 17:39:43 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-19 17:39:43 +0800
commitc844b484159c5a37897540e398960abcdd1f4f19 (patch)
tree7a9694475e79f65995bce2842a3fbc128f9db520 /math/rngstreams
parentcbf89177a8ecfe6aa189b59066fecaca2717455e (diff)
downloadfreebsd-ports-gnome-c844b484159c5a37897540e398960abcdd1f4f19.tar.gz
freebsd-ports-gnome-c844b484159c5a37897540e398960abcdd1f4f19.tar.zst
freebsd-ports-gnome-c844b484159c5a37897540e398960abcdd1f4f19.zip
1: Stagify.
2: USES=libtool, bump version. Approved by: portmgr@
Diffstat (limited to 'math/rngstreams')
-rw-r--r--math/rngstreams/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/math/rngstreams/Makefile b/math/rngstreams/Makefile
index cf80463ace8c..89d1d2e4f0ce 100644
--- a/math/rngstreams/Makefile
+++ b/math/rngstreams/Makefile
@@ -3,35 +3,36 @@
PORTNAME= rngstreams
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://statmath.wu-wien.ac.at/software/RngStreams/
MAINTAINER= bf@FreeBSD.org
COMMENT= A C implementation of a high-quality uniform random number generator
+USES= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-shared
USE_LDCONFIG= yes
PLIST_FILES= lib/librngstreams.a \
- lib/librngstreams.la \
+ lib/librngstreams.so.0.0.0 \
lib/librngstreams.so.0 \
lib/librngstreams.so \
include/RngStream.h
PORTDOCS= rngstreams.txt
PORTEXAMPLES= example1.c
-NO_STAGE= yes
post-install:
.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for DD in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${DD} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${DD} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
.ifndef(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for EE in ${PORTEXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/examples/${EE} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${EE} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.endif