aboutsummaryrefslogtreecommitdiffstats
path: root/math/rocs
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
committermakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
commitcdb81da9cb2b58e688594b552337d1c9bfc47e96 (patch)
treeda82a32e8ce2ded995ae7ba320231491c35220ac /math/rocs
parent904fc890d1dc712abfaeaddde7864519df50915c (diff)
downloadfreebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.gz
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.zst
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.zip
Mk/bsd.kde4.mk:
- Don't set CMAKE_BUILD_TYPE for debug builds (cmake.mk already handles it) - Don't set WITH_DEBUG for unstable branch (KDE4_BRANCH) - Remove now useless KDE4_BUILDENV KDE SC ports: - Chase KDE4_BUILDENV removal: replace 'KDE4_BUILDENV= yes' with 'USES= cmake:outsource' and add USE_LDCONFIG if needed
Diffstat (limited to 'math/rocs')
-rw-r--r--math/rocs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index d4d622d71e72..b8de638150b6 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -15,10 +15,11 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= script scripttools \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>