aboutsummaryrefslogtreecommitdiffstats
path: root/math/ros-geometry
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-06-02 21:46:59 +0800
committerrene <rene@FreeBSD.org>2011-06-02 21:46:59 +0800
commit98dfb41d6522458dd408db0b05a500dee150fc45 (patch)
treea794f8d89166bf801f0609912ea0eadc0c170088 /math/ros-geometry
parentfc25b54821893c80f6e3839734c13d2e314f8939 (diff)
downloadfreebsd-ports-gnome-98dfb41d6522458dd408db0b05a500dee150fc45.tar.gz
freebsd-ports-gnome-98dfb41d6522458dd408db0b05a500dee150fc45.tar.zst
freebsd-ports-gnome-98dfb41d6522458dd408db0b05a500dee150fc45.zip
Make patch-bullet__CMakeLists.txt suitable for upstream.
Diffstat (limited to 'math/ros-geometry')
-rw-r--r--math/ros-geometry/files/patch-bullet__CMakeLists.txt19
1 files changed, 8 insertions, 11 deletions
diff --git a/math/ros-geometry/files/patch-bullet__CMakeLists.txt b/math/ros-geometry/files/patch-bullet__CMakeLists.txt
index 2e776d3577eb..f36e5323b5de 100644
--- a/math/ros-geometry/files/patch-bullet__CMakeLists.txt
+++ b/math/ros-geometry/files/patch-bullet__CMakeLists.txt
@@ -1,22 +1,19 @@
---- bullet/CMakeLists.txt.orig 2011-02-15 01:41:02.000000000 +0100
-+++ bullet/CMakeLists.txt 2011-05-26 00:00:27.000000000 +0200
-@@ -8,13 +8,14 @@
+--- bullet/CMakeLists.txt.orig 2011-05-27 19:54:24.000000000 +0200
++++ bullet/CMakeLists.txt 2011-06-02 14:49:35.000000000 +0200
+@@ -8,13 +8,13 @@
MAKE_DIRECTORY(${PROJECT_SOURCE_DIR}/src/)
# Build Bullet
-if($ENV{MAKE})
-+#if($ENV{MAKE})
++if(NOT "$ENV{MAKE}" STREQUAL "")
execute_process(COMMAND cmake -E chdir ${PROJECT_SOURCE_DIR} $ENV{MAKE} -f Makefile.bullet
RESULT_VARIABLE _make_failed)
-else($ENV{MAKE})
--execute_process(COMMAND cmake -E chdir ${PROJECT_SOURCE_DIR} make -f Makefile.bullet
-- RESULT_VARIABLE _make_failed)
++else(NOT "$ENV{MAKE}" STREQUAL "")
+ execute_process(COMMAND cmake -E chdir ${PROJECT_SOURCE_DIR} make -f Makefile.bullet
+ RESULT_VARIABLE _make_failed)
-endif($ENV{MAKE})
-+#else($ENV{MAKE})
-+#message(FATAL_ERROR "no env, bullet: " $ENV{MAKE})
-+#execute_process(COMMAND cmake -E chdir ${PROJECT_SOURCE_DIR} make -f Makefile.bullet
-+# RESULT_VARIABLE _make_failed)
-+#endif($ENV{MAKE})
++endif(NOT "$$ENV{MAKE}" STREQUAL "")
if(_make_failed)
message(FATAL_ERROR "Build of Bullet failed")
endif(_make_failed)