aboutsummaryrefslogtreecommitdiffstats
path: root/math/rpy2
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-11 19:59:31 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-11 19:59:31 +0800
commit6775ec204c6408f58f8a4dc680c6a82d0dca1921 (patch)
tree3ba474887dbe7b68acd3a7441a9cd37985626a24 /math/rpy2
parent26dd6572988e2395c67d9a04006df531f3f68ec1 (diff)
downloadfreebsd-ports-gnome-6775ec204c6408f58f8a4dc680c6a82d0dca1921.tar.gz
freebsd-ports-gnome-6775ec204c6408f58f8a4dc680c6a82d0dca1921.tar.zst
freebsd-ports-gnome-6775ec204c6408f58f8a4dc680c6a82d0dca1921.zip
math/rpy2: stop linking against math/R depends
While here, switch back to Clang build but keep RPATH which is a quirk to avoid loading /usr/lib/libgcc_s.so during dlopen() race. PR: 214384
Diffstat (limited to 'math/rpy2')
-rw-r--r--math/rpy2/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/rpy2/Makefile b/math/rpy2/Makefile
index 4609945a88d4..9187a6958776 100644
--- a/math/rpy2/Makefile
+++ b/math/rpy2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rpy2
PORTVERSION= 2.7.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= CHEESESHOP
@@ -17,9 +17,9 @@ BUILD_DEPENDS= ${PYNUMPY} \
RUN_DEPENDS= ${PYNUMPY} \
R:math/R
-USES= python readline
-USE_GCC= yes
+USES= fortran python readline
USE_PYTHON= distutils autoplist
+LDFLAGS+= -Wl,--as-needed
pre-configure:
@(if [ ! -e ${LOCALBASE}/lib/R/lib/libR.so ] ; then \