aboutsummaryrefslogtreecommitdiffstats
path: root/math/rpy2
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-05-07 11:29:59 +0800
committerbf <bf@FreeBSD.org>2011-05-07 11:29:59 +0800
commit08b509ea5d7b06897b6cf810c6a58df5a1411d80 (patch)
tree132c0d6a9c4c0ad22c98048b414a6dec7421d1fa /math/rpy2
parent4ff30b9a7287ac0d0ea2e7e3e0899125ecab9c24 (diff)
downloadfreebsd-ports-gnome-08b509ea5d7b06897b6cf810c6a58df5a1411d80.tar.gz
freebsd-ports-gnome-08b509ea5d7b06897b6cf810c6a58df5a1411d80.tar.zst
freebsd-ports-gnome-08b509ea5d7b06897b6cf810c6a58df5a1411d80.zip
- update to 2.13.0
- switch to the bundled Rblas and Rlapack by default (this can be changed by setting BLAS and LAPACK) which favors correctness in some corner cases over a slight performance penalty; this will be revisited after the blas and lapack updates - replace the STATIC_LIBR option with a LIBR option (on by default): if on, libR.a and libR.so are installed, and R is linked to libR.so. Otherwise, R is static, and no libRs are installed. - remove the superfluous copy of libR.so in ${LOCALBASE}/lib [1] - enable the cairo and pango elements in the X11() graphics device by default, controlled by new PANGOCAIRO option - add a few small patches to dependent ports, bumping PORTREVISION where necessary PR: 153309 [1] Approved by: thierry (rkward*), wen (rpy*, R-cran-*)
Diffstat (limited to 'math/rpy2')
-rw-r--r--math/rpy2/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/math/rpy2/Makefile b/math/rpy2/Makefile
index 9b2e38584cdb..1b84100091ad 100644
--- a/math/rpy2/Makefile
+++ b/math/rpy2/Makefile
@@ -8,7 +8,7 @@
PORTNAME= rpy2
PORTVERSION= 2.1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= CHEESESHOP \
SF
@@ -18,7 +18,8 @@ COMMENT= Python interface to the R Programming Language
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
R:${PORTSDIR}/math/R
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
+ R:${PORTSDIR}/math/R
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -26,4 +27,9 @@ USE_PYDISTUTILS= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
+pre-configure:
+ @(if [ ! -e ${LOCALBASE}/lib/R/lib/libR.so ] ; then \
+ ${ECHO_MSG} "==> ${PKGNAME} requires math/R to be built WITH_LIBR" ; \
+ exit 1; fi)
+
.include <bsd.port.mk>