aboutsummaryrefslogtreecommitdiffstats
path: root/math/ruby-algebra/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-05-08 19:13:59 +0800
committerknu <knu@FreeBSD.org>2001-05-08 19:13:59 +0800
commit663157aabfb1c486b6a563a6b0ab17290e8bede7 (patch)
treec00d95fd35fbf31fa53b6e4ca4b34a22480f7f9c /math/ruby-algebra/Makefile
parent300f3b9eb1601ad2edd76f2bc751f390747d2669 (diff)
downloadfreebsd-ports-gnome-663157aabfb1c486b6a563a6b0ab17290e8bede7.tar.gz
freebsd-ports-gnome-663157aabfb1c486b6a563a6b0ab17290e8bede7.tar.zst
freebsd-ports-gnome-663157aabfb1c486b6a563a6b0ab17290e8bede7.zip
Add ruby-algebra, a Ruby library for mathematical (algebraic)
computations.
Diffstat (limited to 'math/ruby-algebra/Makefile')
-rw-r--r--math/ruby-algebra/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/math/ruby-algebra/Makefile b/math/ruby-algebra/Makefile
new file mode 100644
index 000000000000..529b5caf98da
--- /dev/null
+++ b/math/ruby-algebra/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Ruby/Algebra
+# Date created: 8 May 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= algebra
+PORTVERSION= 0.47
+CATEGORIES= math ruby
+MASTER_SITES= http://blade.nagaokaut.ac.jp/~sinara/ruby/math/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS_EN= doc/*.txt doc/*.rd doc/*.html
+DOCS_JA= doc-jp/*.txt doc-jp/*.rd doc-jp/*.html
+
+do-install:
+ ${CP} -R ${WRKSRC}/*.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>