aboutsummaryrefslogtreecommitdiffstats
path: root/math/saga
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2016-03-03 20:09:26 +0800
committerwen <wen@FreeBSD.org>2016-03-03 20:09:26 +0800
commit89f04895084a0da7c83a1c134bb3219e2d47cd6c (patch)
treef739c6b883b59b8e6a22f3e285a8a6b6cf537efa /math/saga
parentb15b4ee0023f8f8f9167fb0d1cf3e346350c1f20 (diff)
downloadfreebsd-ports-gnome-89f04895084a0da7c83a1c134bb3219e2d47cd6c.tar.gz
freebsd-ports-gnome-89f04895084a0da7c83a1c134bb3219e2d47cd6c.tar.zst
freebsd-ports-gnome-89f04895084a0da7c83a1c134bb3219e2d47cd6c.zip
- Update to 2.2.4
PR: 207565 Submitted by: rhurlin@gwdg.de(maintainer)
Diffstat (limited to 'math/saga')
-rw-r--r--math/saga/Makefile11
-rw-r--r--math/saga/distinfo4
-rw-r--r--math/saga/files/patch-src_saga__core_saga__api_table.cpp11
-rw-r--r--math/saga/files/patch-src_saga__core_saga__api_table__io.cpp11
-rw-r--r--math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp31
-rw-r--r--math/saga/files/pkg-message.in2
-rw-r--r--math/saga/pkg-plist27
7 files changed, 32 insertions, 65 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index d110f16a0718..e2a11da75059 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= saga
-PORTVERSION= 2.2.3
+PORTVERSION= 2.2.4
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
-DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= rhurlin@gwdg.de
COMMENT= System for Automated Geoscientific Analyses
@@ -79,11 +78,7 @@ post-extract:
${WRKSRC}/src/modules/statistics/statistics_kriging/Makefile.am
post-patch:
- @${REINPLACE_CMD} -e 's|-lcv|-lopencv_core -lopencv_imgproc|g' \
- ${WRKSRC}/src/modules/imagery/imagery_opencv/Makefile.am
- @${REINPLACE_CMD} -e 's|\[cv\]|\[opencv_core\]|' \
- ${WRKSRC}/configure.ac
- @${REINPLACE_CMD} -e 's|wxString(SAGA_VERSION) + "\\n"|wxString(SAGA_VERSION) + " (SVN r2737)" + "\\n"|' \
+ @${REINPLACE_CMD} -e 's|wxString(SAGA_VERSION) + "\\n"|wxString(SAGA_VERSION) + " (SVN r2832)" + "\\n"|' \
${WRKSRC}/src/saga_core/saga_gui/dlg_about.cpp
.if ${ARCH} == "powerpc"
@${REINPLACE_CMD} -e 's|typedef unsigned long DWORD;|typedef unsigned int DWORD;|' \
@@ -106,6 +101,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.png ${STAGEDIR}${DATADIR}
${MKDIR} ${STAGEDIR}${DATADIR}/scripting
(cd ${WRKSRC}/src/scripting && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/scripting)
+# toolchains only needed in one place
+ @${RM} -R ${STAGEDIR}${DATADIR}/scripting/toolchains
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.desktop \
${STAGEDIR}${PREFIX}/share/applications/
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsaga_api-${PORTVERSION}.so
diff --git a/math/saga/distinfo b/math/saga/distinfo
index e1101fa71481..e7c2bf26a05d 100644
--- a/math/saga/distinfo
+++ b/math/saga/distinfo
@@ -1,2 +1,2 @@
-SHA256 (saga_2.2.3.tar.gz) = f26591c097c8766df9db266bf50e1b38a5bebe0119b44a9b70ae793d0d8bade3
-SIZE (saga_2.2.3.tar.gz) = 4075266
+SHA256 (saga-2.2.4.tar.gz) = efdcb86ce3dcde1b21da2b2d4863b32196bd423588c76d4d5ec301cc93b34582
+SIZE (saga-2.2.4.tar.gz) = 4266724
diff --git a/math/saga/files/patch-src_saga__core_saga__api_table.cpp b/math/saga/files/patch-src_saga__core_saga__api_table.cpp
deleted file mode 100644
index 4480ade6f033..000000000000
--- a/math/saga/files/patch-src_saga__core_saga__api_table.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/saga_core/saga_api/table.cpp.orig 2015-12-21 09:38:29 UTC
-+++ src/saga_core/saga_api/table.cpp
-@@ -175,7 +175,7 @@ bool CSG_Table::Create(const CSG_String
- SG_UI_Msg_Add(CSG_String::Format("%s: %s...", _TL("Load table"), File_Name.c_str()), true);
-
- //-----------------------------------------------------
-- bool bResult = File_Name.BeforeFirst(':').Cmp("PGSQL") && SG_File_Exists(File_Name) && Load(File_Name, (int)Format, NULL);
-+ bool bResult = File_Name.BeforeFirst(':').Cmp("PGSQL") && SG_File_Exists(File_Name) && Load(File_Name, (int)Format, '\0');
-
- if( bResult )
- {
diff --git a/math/saga/files/patch-src_saga__core_saga__api_table__io.cpp b/math/saga/files/patch-src_saga__core_saga__api_table__io.cpp
deleted file mode 100644
index cec27be6b6fe..000000000000
--- a/math/saga/files/patch-src_saga__core_saga__api_table__io.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/saga_core/saga_api/table_io.cpp.orig 2015-12-21 09:38:29 UTC
-+++ src/saga_core/saga_api/table_io.cpp
-@@ -118,7 +118,7 @@ bool CSG_Table::Load(const CSG_String &F
- //---------------------------------------------------------
- bool CSG_Table::Save(const CSG_String &File_Name, int Format)
- {
-- return( Save(File_Name, Format, NULL) );
-+ return( Save(File_Name, Format, '\0') );
- }
-
- //---------------------------------------------------------
diff --git a/math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp b/math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp
index 22e35a90e482..0ebca9155990 100644
--- a/math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp
+++ b/math/saga/files/patch-src_saga__core_saga__gui_dlg__about.cpp
@@ -1,36 +1,23 @@
---- src/saga_core/saga_gui/dlg_about.cpp.orig 2015-12-21 09:38:29 UTC
+--- src/saga_core/saga_gui/dlg_about.cpp.orig 2016-02-28 15:31:41 UTC
+++ src/saga_core/saga_gui/dlg_about.cpp
-@@ -65,6 +65,7 @@
- #include <saga_api/clipper.hpp>
-
- #include <wx/notebook.h>
-+#include <wx/platform.h>
-
- #include "helper.h"
-
-@@ -188,7 +189,7 @@ wxString CDLG_About::_Get_Version(void)
- s += "System for Automated Geoscientific Analyses\n";
- s += "http://www.saga-gis.org\n";
- s += "\n";
-- s += "Version: " + wxString(SAGA_VERSION) + "\n";
-+ s += "Version: " + wxString(SAGA_VERSION) + " (SVN r2737)" + "\n";
-
- #ifdef _SAGA_MSW
- #ifdef _WIN64
-@@ -264,7 +265,21 @@ wxString CDLG_About::_Get_Version(void)
+@@ -264,7 +264,25 @@ wxString CDLG_About::_Get_Version(void)
#elif defined(__GNUWIN32__)
"Gnu-Win32 compiler"
#elif defined(__GNUG__)
- "Gnu C++"
-+ #if wxCHECK_GCC_VERSION(5,1)
++ #if wxCHECK_GCC_VERSION(5,3)
++ "Gnu C++ 5.3"
++ #elif wxCHECK_GCC_VERSION(5,2)
++ "Gnu C++ 5.2"
++ #elif wxCHECK_GCC_VERSION(5,1)
+ "Gnu C++ 5.1"
-+ #elif wxCHECK_GCC_VERSION(5,0)
++ #elif wxCHECK_GCC_VERSION(5,0)
+ "Gnu C++ 5.0"
+ #elif wxCHECK_GCC_VERSION(4,9)
+ "Gnu C++ 4.9"
+ #elif wxCHECK_GCC_VERSION(4,8)
+ "Gnu C++ 4.8"
-+ #elif wxCHECK_GCC_VERSION(4,7)
++ #elif wxCHECK_GCC_VERSION(4,7)
+ "Gnu C++ 4.7"
+ #elif wxCHECK_GCC_VERSION(4,6)
+ "Gnu C++ 4.6"
diff --git a/math/saga/files/pkg-message.in b/math/saga/files/pkg-message.in
index 2d99f7c1309a..a8e903615b7a 100644
--- a/math/saga/files/pkg-message.in
+++ b/math/saga/files/pkg-message.in
@@ -23,7 +23,7 @@ modules.
From SAGA GIS 2.2.0 on, there is some example and test data installed.
Predefined ToolChains are located at
- %%DATADIR%%/scripting/toolchains/
+ %%DATADIR%%/toolchains/
Python scripts with examples, helpers and test data reside at
%%DATADIR%%/scripting/python/
diff --git a/math/saga/pkg-plist b/math/saga/pkg-plist
index 9fa447aba4e2..5ae7829e3c83 100644
--- a/math/saga/pkg-plist
+++ b/math/saga/pkg-plist
@@ -150,14 +150,19 @@ share/pixmaps/saga.png
%%DATADIR%%/scripting/python/test_data/test_pts.shp
%%DATADIR%%/scripting/python/test_data/test_pts.shx
%%DATADIR%%/scripting/python/test_data/test_pts_xyz.xyz
-%%DATADIR%%/scripting/toolchains/cluster_terrain.xml
-%%DATADIR%%/scripting/toolchains/gridding.xml
-%%DATADIR%%/scripting/toolchains/imagery_lczc.xml
-%%DATADIR%%/scripting/toolchains/obia.xml
-%%DATADIR%%/scripting/toolchains/points_to_contour.xml
-%%DATADIR%%/scripting/toolchains/sieve_and_clump.xml
-%%DATADIR%%/scripting/toolchains/temperature_downscaling.xml
-%%DATADIR%%/scripting/toolchains/terrain_analysis.xml
-%%DATADIR%%/scripting/toolchains/terrain_segmentation.xml
-%%DATADIR%%/scripting/toolchains/twi.xml
-%%DATADIR%%/scripting/toolchains/upslope_height.xml
+%%DATADIR%%/toolchains/climate.xml
+%%DATADIR%%/toolchains/cluster_terrain.xml
+%%DATADIR%%/toolchains/gridding.xml
+%%DATADIR%%/toolchains/imagery.xml
+%%DATADIR%%/toolchains/imagery_lczc.xml
+%%DATADIR%%/toolchains/obia.xml
+%%DATADIR%%/toolchains/points_to_contour.xml
+%%DATADIR%%/toolchains/sieve_and_clump.xml
+%%DATADIR%%/toolchains/temperature_downscaling.xml
+%%DATADIR%%/toolchains/terrain_analysis.xml
+%%DATADIR%%/toolchains/terrain_segmentation.xml
+%%DATADIR%%/toolchains/tta_LandCover.xml
+%%DATADIR%%/toolchains/tta_TravelTime.xml
+%%DATADIR%%/toolchains/tta_tools.xml
+%%DATADIR%%/toolchains/twi.xml
+%%DATADIR%%/toolchains/upslope_height.xml