aboutsummaryrefslogtreecommitdiffstats
path: root/math/saga
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-10-20 04:46:32 +0800
committerpawel <pawel@FreeBSD.org>2011-10-20 04:46:32 +0800
commita559cdc6e90bfe7102ba055de0399dbb59120e4e (patch)
tree96f47b1aff357f0856d344a1cac73d28ae7606ec /math/saga
parentbd3c97817636299e59d267e07bdef58f329ed10d (diff)
downloadfreebsd-ports-gnome-a559cdc6e90bfe7102ba055de0399dbb59120e4e.tar.gz
freebsd-ports-gnome-a559cdc6e90bfe7102ba055de0399dbb59120e4e.tar.zst
freebsd-ports-gnome-a559cdc6e90bfe7102ba055de0399dbb59120e4e.zip
Fix segfault in saga_cmd
PR: ports/161781 Submitted by: Rainer Hurling <rhurlin@gwdg.de> (maintainer)
Diffstat (limited to 'math/saga')
-rw-r--r--math/saga/Makefile2
-rw-r--r--math/saga/files/patch-src__saga_core__saga_cmd__saga_cmd.cpp13
2 files changed, 14 insertions, 1 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index d83a7111c2f3..63128d27d868 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= saga
PORTVERSION= 2.0.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/math/saga/files/patch-src__saga_core__saga_cmd__saga_cmd.cpp b/math/saga/files/patch-src__saga_core__saga_cmd__saga_cmd.cpp
new file mode 100644
index 000000000000..5dd463eea824
--- /dev/null
+++ b/math/saga/files/patch-src__saga_core__saga_cmd__saga_cmd.cpp
@@ -0,0 +1,13 @@
+--- src/saga_core/saga_cmd/saga_cmd.cpp_orig 2011-05-17 15:36:45.000000000 +0200
++++ src/saga_core/saga_cmd/saga_cmd.cpp 2011-10-17 08:25:58.000000000 +0200
+@@ -126,7 +126,11 @@
+ #endif
+ //---------------------------------------------------------
+
++#if wxCHECK_VERSION(2, 8, 11)
++ if( !wxInitialize( argc, argv ) )
++#else
+ if( !wxInitialize() )
++#endif
+ {
+ Print_Error(SG_T("initialisation failed"));