aboutsummaryrefslogtreecommitdiffstats
path: root/math/sage
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2012-05-15 20:57:27 +0800
committerstephen <stephen@FreeBSD.org>2012-05-15 20:57:27 +0800
commit1d65a0a9051bf7ee6f6a06b4887f6ef0af9b7c4e (patch)
tree0e5b7c82bf9417c2223870e524306687af094a5a /math/sage
parent673e8cdc92081f8437bea6cb35679a465b60aa40 (diff)
downloadfreebsd-ports-gnome-1d65a0a9051bf7ee6f6a06b4887f6ef0af9b7c4e.tar.gz
freebsd-ports-gnome-1d65a0a9051bf7ee6f6a06b4887f6ef0af9b7c4e.tar.zst
freebsd-ports-gnome-1d65a0a9051bf7ee6f6a06b4887f6ef0af9b7c4e.zip
- Use use_autotools to add autoconf dependency.
Diffstat (limited to 'math/sage')
-rw-r--r--math/sage/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index de2cf56f8852..6e1d85ecc4e0 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -18,8 +18,7 @@ MAINTAINER= stephen@FreeBSD.org
COMMENT= Open source Mathematics software
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
- latex:${PORTSDIR}/print/teTeX-base \
- autoconf-2.68:${PORTSDIR}/devel/autoconf
+ latex:${PORTSDIR}/print/teTeX-base
LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas \
lapack:${PORTSDIR}/math/lapack \
jpeg:${PORTSDIR}/graphics/jpeg
@@ -86,6 +85,12 @@ CXXFLAGS+= -Wl,-rpath=${WRKSRC}/local/lib ${FPM_FLAG}
# work-around for the make(1) idiosyncracy mentioned in PR 164361 (which
# otherwise breaks the build of the maxima sub-package).
+USE_AUTOTOOLS= autoconf
+run-autotools:
+ @${DO_NADA}
+do-configure:
+ @${DO_NADA}
+
.include <bsd.port.pre.mk>
.if defined(WITH_4TI2) || defined(WITH_TOPCOM) || defined(WITH_BIOPYTHON) || \