aboutsummaryrefslogtreecommitdiffstats
path: root/math/sage
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2012-02-01 08:20:29 +0800
committerstephen <stephen@FreeBSD.org>2012-02-01 08:20:29 +0800
commitf0bccbac4d5bf85a5804c00c5983a806e11d78ee (patch)
tree8b453551abeb8cb83daddfcd17341478cfcafa87 /math/sage
parent1caab794d83e482cccbae97ea7bdc410c192ca62 (diff)
downloadfreebsd-ports-gnome-f0bccbac4d5bf85a5804c00c5983a806e11d78ee.tar.gz
freebsd-ports-gnome-f0bccbac4d5bf85a5804c00c5983a806e11d78ee.tar.zst
freebsd-ports-gnome-f0bccbac4d5bf85a5804c00c5983a806e11d78ee.zip
- Small changes to post-patch target so that it can be restarted.
- Switch off parallel builds if FreeBSD version>=9 (hoping to get some useful feedback from tinderbox builds, as parallel building mangles the log).
Diffstat (limited to 'math/sage')
-rw-r--r--math/sage/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 4348f5aeb5d0..c11964f3e089 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -55,11 +55,11 @@ post-patch:
@${LN} -s -f ${LOCALBASE}/bin/gmake ${WRKSRC}/local/bin/make
@${LN} -s -f ${LOCALBASE}/bin/bash ${WRKSRC}/local/bin/sh
@${SED} -e 's#%%CC%%#${LOCALBASE}/bin/${CC}#' -e 's#%%CFLAGS%%#${CFLAGS}#' ${FILESDIR}/gcc.in > ${WRKSRC}/local/bin/cc
- @${CHMOD} ${BINMODE} ${WRKSRC}/local/bin/cc
- @${LN} -s cc ${WRKSRC}/local/bin/gcc
+ @${CHMOD} +x ${WRKSRC}/local/bin/cc
+ @${LN} -s -f cc ${WRKSRC}/local/bin/gcc
@${SED} -e 's#%%CC%%#${LOCALBASE}/bin/${CXX}#' -e 's#%%CFLAGS%%#${CXXFLAGS}#' ${FILESDIR}/gcc.in > ${WRKSRC}/local/bin/c++
- @${CHMOD} ${BINMODE} ${WRKSRC}/local/bin/c++
- @${LN} -s c++ ${WRKSRC}/local/bin/g++
+ @${CHMOD} +x ${WRKSRC}/local/bin/c++
+ @${LN} -s -f c++ ${WRKSRC}/local/bin/g++
@${SED} -e 's#%%CC%%#${LOCALBASE}/bin/${FC}#' -e 's#%%CFLAGS%%#${FFLAGS}#' ${FILESDIR}/gcc.in > ${WRKSRC}/local/bin/gfortran
@${CHMOD} +x ${WRKSRC}/local/bin/gfortran
@${MKDIR} ${WRKSRC}/tmp
@@ -96,7 +96,7 @@ post-patch:
IGNORE= POSIX semaphores are required, and the support only works in FreeBSD 7-STABLE and later
.endif
-.if !defined(DISABLE_MAKE_JOBS)
+.if !defined(DISABLE_MAKE_JOBS) && ${OSVERSION} < 900000
MAKE_ENV+= MAKE="make -j${MAKE_JOBS_NUMBER}"
.endif